From: "Luis R. Rodriguez" <mcgrof@suse.com>
To: Ingo Molnar <mingo@kernel.org>
Cc: "Luis R. Rodriguez" <mcgrof@do-not-panic.com>,
mingo@elte.hu, vinod.koul@intel.com, dan.j.williams@intel.com,
dmaengine@vger.kernel.org, linux-kernel@vger.kernel.org,
benh@kernel.crashing.org
Subject: Re: [PATCH v2 0/2] dma: rename write-combine APIs with short form
Date: Tue, 28 Jul 2015 01:58:50 +0200 [thread overview]
Message-ID: <20150727235850.GX30479@wotan.suse.de> (raw)
In-Reply-To: <20150718034242.GB21260@gmail.com>
On Sat, Jul 18, 2015 at 05:42:42AM +0200, Ingo Molnar wrote:
>
> * Luis R. Rodriguez <mcgrof@suse.com> wrote:
>
> > On Thu, Jul 09, 2015 at 06:34:22PM -0700, Luis R. Rodriguez wrote:
> > > From: "Luis R. Rodriguez" <mcgrof@suse.com>
> > >
> > > Ingo,
> > >
> > > You had asked for this to be kept in my tree until the end of the
> > > merge window. I sent it a bit earlier than the end of the merge window,
> > > it failed to apply to Boris' tree as my series was based on linux-next
> > > and then I went on a small vacation. Boris is now on vacation as well.
> > > I've respinned this series today -- and fortunatley both of the patches
> > > in this series apply to both Linus' tree and linux-next, I am in hopes
> > > it applies to any other tree as well without conflicts. If not it should
> > > be easy to respin with the Coccinelle SmPL rule defined.
> > >
> > > I'll note that there are a few outstanding series related to MTRR, but
> > > those do not have conflicts with these patches at all so feel free
> > > to consider these before or after. Also I tried to get an ack for the
> > > first patch [1] but that has gone under the radar I believe so
> > > merging it now as part of this series and Cc'ing the maintainers.
> > > That change is needed in order to make the code match the grammar
> > > used by Coccinelle used in the expressed transformation.
> > >
> > > [0] http://lkml.kernel.org/r/20150601085332.GA14549@gmail.com
> > > [1] http://lkml.kernel.org/r/1434483609-25498-1-git-send-email-mcgrof@do-not-panic.com
> > >
> > > Luis R. Rodriguez (2):
> > > drivers/dma/iop-adma: Use dma_alloc_writecombine() kernel-style
> > > dma: rename dma_*_writecombine() to dma_*_wc()
> >
> > This series requires some adjustments based on linux-next. Do we accept renames
> > on -rcs? If so should I respin? If its too late for v4.2 I can try to shoot for
> > v4.3 but timing sending this at the right exact time seems a bit hard so any
> > advice for that is highly appreciated.
>
> Could you please also add the old API names as aliases, so that we won't break the
> build if some driver bleeds in the old API use via linux-next? Then we can remove
> the old APIs in a kernel cycle or two.
>
> It doesn't look too bad so I'll apply this (for v4.3) once you've done that and
> will carry it.
Sure, I'll be re-spinning now.
Luis
prev parent reply other threads:[~2015-07-27 23:58 UTC|newest]
Thread overview: 8+ messages / expand[flat|nested] mbox.gz Atom feed top
2015-07-10 1:34 Luis R. Rodriguez
2015-07-10 1:34 ` [PATCH v2 1/2] drivers/dma/iop-adma: Use dma_alloc_writecombine() kernel-style Luis R. Rodriguez
2015-07-23 17:23 ` Vinod Koul
2015-07-24 18:59 ` Luis R. Rodriguez
2015-07-10 1:34 ` [PATCH v2 2/2] dma: rename dma_*_writecombine() to dma_*_wc() Luis R. Rodriguez
2015-07-17 20:35 ` [PATCH v2 0/2] dma: rename write-combine APIs with short form Luis R. Rodriguez
2015-07-18 3:42 ` Ingo Molnar
2015-07-27 23:58 ` Luis R. Rodriguez [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20150727235850.GX30479@wotan.suse.de \
--to=mcgrof@suse.com \
--cc=benh@kernel.crashing.org \
--cc=dan.j.williams@intel.com \
--cc=dmaengine@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=mcgrof@do-not-panic.com \
--cc=mingo@elte.hu \
--cc=mingo@kernel.org \
--cc=vinod.koul@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®