From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1757550AbbHDPXx (ORCPT ); Tue, 4 Aug 2015 11:23:53 -0400 Received: from smtprelay0228.hostedemail.com ([216.40.44.228]:40900 "EHLO smtprelay.hostedemail.com" rhost-flags-OK-OK-OK-FAIL) by vger.kernel.org with ESMTP id S1753575AbbHDOlO (ORCPT ); Tue, 4 Aug 2015 10:41:14 -0400 X-Session-Marker: 726F737465647440676F6F646D69732E6F7267 X-Spam-Summary: 50,3,0,,d41d8cd98f00b204,rostedt@goodmis.org,:::::::::::::::::::::::::::::::::,RULES_HIT:41:355:379:541:599:800:960:973:988:989:1260:1277:1311:1313:1314:1345:1359:1437:1515:1516:1518:1534:1540:1593:1594:1711:1730:1747:1777:1792:2393:2553:2559:2562:3138:3139:3140:3141:3142:3167:3352:3622:3865:3866:3867:3868:3870:3871:3872:3874:4250:5007:6261:6742:7875:7903:9040:10004:10400:10848:10967:11026:11232:11658:11914:12517:12519:12663:12740:12991:13069:13161:13229:13311:13357:14096:14097:21080,0,RBL:none,CacheIP:none,Bayesian:0.5,0.5,0.5,Netcheck:none,DomainCache:0,MSF:not bulk,SPF:fn,MSBL:0,DNSBL:none,Custom_rules:0:0:0 X-HE-Tag: nut68_27867313a0e09 X-Filterd-Recvd-Size: 2506 Date: Tue, 4 Aug 2015 10:41:10 -0400 From: Steven Rostedt To: Borislav Petkov Cc: Peter Zijlstra , Vlastimil Babka , linux-kernel@vger.kernel.org, mingo@kernel.org, jasonbaron0@gmail.com, luto@amacapital.net, tglx@linutronix.de, will.deacon@arm.com, liuj97@gmail.com, rabin@rab.in, ralf@linux-mips.org, ddaney@caviumnetworks.com, benh@kernel.crashing.org, michael@ellerman.id.au, heiko.carstens@de.ibm.com, davem@davemloft.net Subject: Re: [PATCH -v2 6/8] jump_label: Add a new static_key interface Message-ID: <20150804104110.01676ca1@gandalf.local.home> In-Reply-To: <20150804143344.GA5689@nazgul.tnic> References: <20150728132313.164884020@infradead.org> <55B87E7A.2070509@suse.cz> <20150729084906.GH19282@twins.programming.kicks-ass.net> <20150803150359.0e76b576@gandalf.local.home> <20150803191816.GC25159@twins.programming.kicks-ass.net> <20150803152810.5a7bcf06@gandalf.local.home> <20150803200002.GE25159@twins.programming.kicks-ass.net> <20150803175757.2adf3275@gandalf.local.home> <20150804033733.GB31787@nazgul.tnic> <20150804080645.0f29617d@gandalf.local.home> <20150804143344.GA5689@nazgul.tnic> X-Mailer: Claws Mail 3.11.1 (GTK+ 2.24.28; x86_64-pc-linux-gnu) MIME-Version: 1.0 Content-Type: text/plain; charset=US-ASCII Content-Transfer-Encoding: 7bit Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Tue, 4 Aug 2015 16:33:44 +0200 Borislav Petkov wrote: > Hell, we can drop that "key" or "branch" from the whole API for all I > know. "static_" is enough for me to say what the thing is. But that's > just me - I like short names - no poems in code and sh*t. > > Thoughts, comments? I agree to get rid of the "key" and the "branch", I never liked them in the first place. I prefer static_set_true/false() but I'm also fine with static_enable/disable() as long as the initializers are consistent. > > So yeah, I absolutely see the problematic here and also the need for > more bikeshedding. And this time, that bikeshedding is important. > Right, because the broken part of this nuclear plant, was the bike shed, and it's color was so ugly that the people in the nuclear plant kept making mistakes by being distracted by that damn shed! -- Steve