From: Peter Zijlstra <peterz@infradead.org>
To: Will Deacon <will.deacon@arm.com>
Cc: linux-arch@vger.kernel.org, Waiman.Long@hp.com,
linux-kernel@vger.kernel.org, paulmck@linux.vnet.ibm.com,
mingo@kernel.org
Subject: Re: [PATCH v5 0/8] Add generic support for relaxed atomics
Date: Fri, 7 Aug 2015 17:13:03 +0200 [thread overview]
Message-ID: <20150807151303.GM16853@twins.programming.kicks-ass.net> (raw)
In-Reply-To: <1438880084-18856-1-git-send-email-will.deacon@arm.com>
On Thu, Aug 06, 2015 at 05:54:36PM +0100, Will Deacon wrote:
> Hi all,
> The series adds support for a family of relaxed atomics to the kernel.
> More specifically:
>
> - acquire/release/relaxed flavours of xchg, cmpxchg and {add,sub}_return
> - atomic_read_acquire
> - atomic_set_release
>
> This came out of a separate patch series porting the (barrier-heavy)
> qrwlock code to arm64. Rather than have arch-specific hooks littered
> around the place, it makes more sense to define a core set of relaxed
> atomics that can be used regardless of architecture.
>
> Changes since v4 are:
>
> * Drop the ret_t macro parameter in favour of typeof tricks (Peter Z)
>
> * Add a missing acquire to the qrwlock code, as it was based on a
> previous patch that I posted (Waiman Long)
>
> Build tested on ARM, arm64, PowerPC and x86.
Queued it. There was a wee conflict with the atomic_{and,or,xor} bits
for the ARM patch, but that was quickly sorted.
Does we want a Documentation/ update to reflect all this shiny new
stuff?
next prev parent reply other threads:[~2015-08-07 15:13 UTC|newest]
Thread overview: 22+ messages / expand[flat|nested] mbox.gz Atom feed top
2015-08-06 16:54 Will Deacon
2015-08-06 16:54 ` [PATCH v5 1/8] atomics: add acquire/release/relaxed variants of some atomic operations Will Deacon
2015-08-12 12:34 ` [tip:locking/core] locking/atomics: Add _{acquire|release|relaxed}() " tip-bot for Will Deacon
2015-08-06 16:54 ` [PATCH v5 2/8] asm-generic: rework atomic-long.h to avoid bulk code duplication Will Deacon
2015-08-12 12:34 ` [tip:locking/core] locking, asm-generic: Rework " tip-bot for Will Deacon
2015-08-06 16:54 ` [PATCH v5 3/8] asm-generic: add relaxed/acquire/release variants for atomic_long_t Will Deacon
2015-08-12 12:35 ` [tip:locking/core] locking, asm-generic: Add _{relaxed|acquire|release}() variants for 'atomic_long_t' tip-bot for Will Deacon
2015-08-06 16:54 ` [PATCH v5 4/8] lockref: remove homebrew cmpxchg64_relaxed macro definition Will Deacon
2015-08-12 12:35 ` [tip:locking/core] locking/lockref: Remove homebrew cmpxchg64_relaxed() " tip-bot for Will Deacon
2015-08-06 16:54 ` [PATCH v5 5/8] locking/qrwlock: implement queue_write_unlock using smp_store_release Will Deacon
2015-08-12 12:35 ` [tip:locking/core] locking/qrwlock: Implement queue_write_unlock( ) using smp_store_release() tip-bot for Will Deacon
2015-08-06 16:54 ` [PATCH v5 6/8] locking/qrwlock: make use of acquire/release/relaxed atomics Will Deacon
2015-08-12 12:36 ` [tip:locking/core] locking/qrwlock: Make use of _{acquire|release|relaxed}() atomics tip-bot for Will Deacon
2015-08-06 16:54 ` [PATCH v5 7/8] include/llist: use linux/atomic.h instead of asm/cmpxchg.h Will Deacon
2015-08-12 12:36 ` [tip:locking/core] locking, include/llist: Use linux/ atomic.h " tip-bot for Will Deacon
2015-08-06 16:54 ` [PATCH v5 8/8] ARM: atomics: define our SMP atomics in terms of _relaxed operations Will Deacon
2015-08-12 12:36 ` [tip:locking/core] locking, ARM, atomics: Define our SMP atomics in terms of _relaxed() operations tip-bot for Will Deacon
2015-08-07 15:13 ` Peter Zijlstra [this message]
2015-08-07 16:29 ` [PATCH v5 0/8] Add generic support for relaxed atomics Will Deacon
2015-08-26 4:28 ` Boqun Feng
2015-08-26 10:41 ` Will Deacon
2015-08-26 11:35 ` Boqun Feng
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20150807151303.GM16853@twins.programming.kicks-ass.net \
--to=peterz@infradead.org \
--cc=Waiman.Long@hp.com \
--cc=linux-arch@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@kernel.org \
--cc=paulmck@linux.vnet.ibm.com \
--cc=will.deacon@arm.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome