From: Bjorn Helgaas <bhelgaas@google.com>
To: Yinghai Lu <yinghai@kernel.org>
Cc: David Miller <davem@davemloft.net>,
Benjamin Herrenschmidt <benh@kernel.crashing.org>,
Wei Yang <weiyang@linux.vnet.ibm.com>, TJ <linux@iam.tj>,
Yijing Wang <wangyijing@huawei.com>,
Andrew Morton <akpm@linux-foundation.org>,
linux-pci@vger.kernel.org, linux-kernel@vger.kernel.org,
"Rafael J. Wysocki" <rjw@rjwysocki.net>,
Len Brown <lenb@kernel.org>,
linux-acpi@vger.kernel.org
Subject: Re: [PATCH v3 13/51] PCI: Separate realloc list checking after allocation
Date: Mon, 17 Aug 2015 18:54:16 -0500 [thread overview]
Message-ID: <20150817235416.GS26431@google.com> (raw)
In-Reply-To: <1438039809-24957-14-git-send-email-yinghai@kernel.org>
On Mon, Jul 27, 2015 at 04:29:31PM -0700, Yinghai Lu wrote:
> We check the realloc list, as list must be empty after allocation.
>
> Separate the realloc list checking to another function.
>
> Add checking that is missed in acpiphp driver.
>
> Signed-off-by: Yinghai Lu <yinghai@kernel.org>
> Cc: "Rafael J. Wysocki" <rjw@rjwysocki.net>
> Cc: Len Brown <lenb@kernel.org>
> Cc: linux-acpi@vger.kernel.org
> ---
> drivers/pci/hotplug/acpiphp_glue.c | 1 +
> drivers/pci/pci.h | 1 +
> drivers/pci/setup-bus.c | 11 ++++++++---
> 3 files changed, 10 insertions(+), 3 deletions(-)
>
> diff --git a/drivers/pci/hotplug/acpiphp_glue.c b/drivers/pci/hotplug/acpiphp_glue.c
> index ff53856..134caee 100644
> --- a/drivers/pci/hotplug/acpiphp_glue.c
> +++ b/drivers/pci/hotplug/acpiphp_glue.c
> @@ -507,6 +507,7 @@ static void enable_slot(struct acpiphp_slot *slot)
> }
> }
> __pci_bus_assign_resources(bus, &add_list, NULL);
> + __pci_bus_check_realloc(&add_list);
>
> acpiphp_sanitize_bus(bus);
> pcie_bus_configure_settings(bus);
> diff --git a/drivers/pci/pci.h b/drivers/pci/pci.h
> index 4ff0ff1..2b83977 100644
> --- a/drivers/pci/pci.h
> +++ b/drivers/pci/pci.h
> @@ -235,6 +235,7 @@ void __pci_bus_size_bridges(struct pci_bus *bus,
> void __pci_bus_assign_resources(const struct pci_bus *bus,
> struct list_head *realloc_head,
> struct list_head *fail_head);
> +void __pci_bus_check_realloc(struct list_head *realloc_head);
> bool pci_bus_clip_resource(struct pci_dev *dev, int idx);
>
> void pci_reassigndev_resource_alignment(struct pci_dev *dev);
> diff --git a/drivers/pci/setup-bus.c b/drivers/pci/setup-bus.c
> index 06664db..f30225c 100644
> --- a/drivers/pci/setup-bus.c
> +++ b/drivers/pci/setup-bus.c
> @@ -350,6 +350,11 @@ out:
> }
> }
>
> +void __pci_bus_check_realloc(struct list_head *realloc_head)
> +{
> + BUG_ON(!list_empty(realloc_head));
I don't think this really improves readability. At least before, we could
see what we were looking for and we knew it might BUG().
> +}
> +
> /**
> * assign_requested_resources_sorted() - satisfy resource requests
> *
> @@ -1861,7 +1866,7 @@ again:
> /* Depth last, allocate resources and update the hardware. */
> __pci_bus_assign_resources(bus, add_list, &fail_head);
> if (add_list)
> - BUG_ON(!list_empty(add_list));
> + __pci_bus_check_realloc(add_list);
> tried_times++;
>
> /* any device complain? */
> @@ -1936,7 +1941,7 @@ void pci_assign_unassigned_bridge_resources(struct pci_dev *bridge)
> again:
> __pci_bus_size_bridges(parent, &add_list);
> __pci_bridge_assign_resources(bridge, &add_list, &fail_head);
> - BUG_ON(!list_empty(&add_list));
> + __pci_bus_check_realloc(&add_list);
> tried_times++;
>
> if (list_empty(&fail_head))
> @@ -1995,6 +2000,6 @@ void pci_assign_unassigned_bus_resources(struct pci_bus *bus)
> &add_list);
> up_read(&pci_bus_sem);
> __pci_bus_assign_resources(bus, &add_list, NULL);
> - BUG_ON(!list_empty(&add_list));
> + __pci_bus_check_realloc(&add_list);
> }
> EXPORT_SYMBOL_GPL(pci_assign_unassigned_bus_resources);
> --
> 1.8.4.5
>
next prev parent reply other threads:[~2015-08-17 23:54 UTC|newest]
Thread overview: 81+ messages / expand[flat|nested] mbox.gz Atom feed top
2015-07-27 23:29 [PATCH v3 00/51] PCI: Resource allocation cleanup for v4.3 Yinghai Lu
2015-07-27 23:29 ` [PATCH v3 01/51] PCI: Cleanup res_to_dev_res() printout for addon resources Yinghai Lu
2015-08-17 22:50 ` Bjorn Helgaas
2015-08-18 21:19 ` Yinghai Lu
2015-07-27 23:29 ` [PATCH v3 02/51] PCI: Reuse res_to_dev_res in reassign_resources_sorted Yinghai Lu
2015-07-27 23:29 ` [PATCH v3 03/51] PCI: Use correct align for optional only resources during sorting Yinghai Lu
2015-08-17 23:00 ` Bjorn Helgaas
2015-08-18 19:01 ` Yinghai Lu
2015-07-27 23:29 ` [PATCH v3 04/51] PCI: Optimize bus align/size calculation during sizing Yinghai Lu
2015-08-17 23:49 ` Bjorn Helgaas
2015-08-18 20:29 ` Yinghai Lu
2015-07-27 23:29 ` [PATCH v3 05/51] PCI: Optimize bus align/size calculation for optional " Yinghai Lu
2015-07-27 23:29 ` [PATCH v3 06/51] PCI: Don't add too much optional size for hotplug bridge mmio Yinghai Lu
2015-07-27 23:29 ` [PATCH v3 07/51] PCI: Reorder resources list for must/optional resources Yinghai Lu
2015-08-17 23:52 ` Bjorn Helgaas
2015-08-18 20:58 ` Yinghai Lu
2015-07-27 23:29 ` [PATCH v3 08/51] PCI: Remove duplicated code for resource sorting Yinghai Lu
2015-07-27 23:29 ` [PATCH v3 09/51] PCI: Rename pdev_sort_resources to pdev_check_resources Yinghai Lu
2015-08-17 23:53 ` Bjorn Helgaas
2015-08-18 21:36 ` Yinghai Lu
2015-08-18 21:45 ` Yinghai Lu
2015-07-27 23:29 ` [PATCH v3 10/51] PCI: Treat ROM resource as optional during realloc Yinghai Lu
2015-07-27 23:29 ` [PATCH v3 11/51] PCI: Add debug printout during releasing partial assigned resources Yinghai Lu
2015-07-27 23:29 ` [PATCH v3 12/51] PCI: Simplify res reference using in __assign_resourcs_sorted Yinghai Lu
2015-07-27 23:29 ` [PATCH v3 13/51] PCI: Separate realloc list checking after allocation Yinghai Lu
2015-08-17 23:54 ` Bjorn Helgaas [this message]
2015-08-18 21:58 ` Yinghai Lu
2015-07-27 23:29 ` [PATCH v3 14/51] PCI: Add __add_to_list() Yinghai Lu
2015-07-27 23:29 ` [PATCH v3 15/51] PCI: Cache window alignment value Yinghai Lu
2015-07-27 23:29 ` [PATCH v3 16/51] PCI: Check if resource is allocated before pci_assign Yinghai Lu
2015-07-27 23:29 ` [PATCH v3 17/51] PCI: Separate out save_resources/restore_resource Yinghai Lu
2015-07-27 23:29 ` [PATCH v3 18/51] PCI: Move comment to pci_need_to_release() Yinghai Lu
2015-07-27 23:29 ` [PATCH v3 19/51] PCI: Separate must+optional assigning to another function Yinghai Lu
2015-07-27 23:29 ` [PATCH v3 20/51] PCI: Skip must+optional if there is no optional addon Yinghai Lu
2015-08-17 23:56 ` Bjorn Helgaas
2015-08-18 22:39 ` Yinghai Lu
2015-07-27 23:29 ` [PATCH v3 21/51] PCI: Move saved required resource list out of must+optional assigning Yinghai Lu
2015-07-27 23:29 ` [PATCH v3 22/51] PCI: Add alt_size allocation support Yinghai Lu
2015-08-18 0:03 ` Bjorn Helgaas
2015-08-19 5:28 ` Yinghai Lu
2015-07-27 23:29 ` [PATCH v3 23/51] PCI: Add support for more than two alt_size under same bridge Yinghai Lu
2015-07-27 23:29 ` [PATCH v3 24/51] PCI: Better support for two alt_size Yinghai Lu
2015-07-27 23:29 ` [PATCH v3 25/51] PCI: Fix size calculation with old_size on rescan path Yinghai Lu
2015-08-18 4:09 ` Bjorn Helgaas
2015-08-19 6:25 ` Yinghai Lu
2015-07-27 23:29 ` [PATCH v3 26/51] PCI: Don't add too much optional size for hotplug bridge io Yinghai Lu
2015-07-27 23:29 ` [PATCH v3 27/51] PCI: Move ISA ioport align out of calculate_iosize Yinghai Lu
2015-08-18 4:11 ` Bjorn Helgaas
2015-08-19 6:32 ` Yinghai Lu
2015-07-27 23:29 ` [PATCH v3 28/51] PCI: Unifiy calculate_size for io port and mmio Yinghai Lu
2015-08-18 4:13 ` Bjorn Helgaas
2015-08-19 6:37 ` Yinghai Lu
2015-07-27 23:29 ` [PATCH v3 29/51] PCI: Allow optional only io resource must size to be 0 Yinghai Lu
2015-07-27 23:29 ` [PATCH v3 30/51] PCI: Unify skip_ioresource_align() Yinghai Lu
2015-07-27 23:29 ` [PATCH v3 31/51] PCI: Kill macro checking for bus io port sizing Yinghai Lu
2015-07-27 23:29 ` [PATCH v3 32/51] resources: Split out __allocate_resource() Yinghai Lu
2015-08-18 4:14 ` Bjorn Helgaas
2015-08-19 6:58 ` Yinghai Lu
2015-07-27 23:29 ` [PATCH v3 33/51] resources: Make allocate_resource return just fit resource Yinghai Lu
2015-08-18 4:21 ` Bjorn Helgaas
2015-08-19 7:22 ` Yinghai Lu
2015-07-27 23:29 ` [PATCH v3 34/51] PCI: Check pref compatible bit for mem64 resource of pcie device Yinghai Lu
2015-07-27 23:29 ` [PATCH v3 35/51] PCI: Only treat non-pef mmio64 as pref if all bridges has MEM_64 Yinghai Lu
2015-07-27 23:29 ` [PATCH v3 36/51] PCI: Add has_mem64 for host_bridge Yinghai Lu
2015-07-27 23:29 ` [PATCH v3 37/51] PCI: Only treat non-pef mmio64 as pref if host-bridge has_mem64 Yinghai Lu
2015-07-27 23:29 ` [PATCH v3 38/51] PCI: Restore pref mmio allocation logic for hostbridge without mmio64 Yinghai Lu
2015-07-27 23:29 ` [PATCH v3 39/51] sparc/PCI: Add mem64 resource parsing for root bus Yinghai Lu
2015-07-27 23:29 ` [PATCH v3 40/51] sparc/PCI: Add IORESOURCE_MEM_64 for 64-bit resource in of parsing Yinghai Lu
2015-07-27 23:29 ` [PATCH v3 41/51] powerpc/PCI: " Yinghai Lu
2015-07-27 23:30 ` [PATCH v3 42/51] of/PCI: Add IORESOURCE_MEM_64 for 64-bit resource Yinghai Lu
2015-07-27 23:30 ` [PATCH v3 43/51] PCI: Treat optional as must in first try for bridge rescan Yinghai Lu
2015-07-27 23:30 ` [PATCH v3 44/51] PCI: Get new realloc size for bridge for last try Yinghai Lu
2015-07-27 23:30 ` [PATCH v3 45/51] PCI: Don't release sibiling bridge resources during hotplug Yinghai Lu
2015-07-27 23:30 ` [PATCH v3 46/51] PCI: Don't release fixed resource for realloc Yinghai Lu
2015-07-27 23:30 ` [PATCH v3 47/51] PCI: Claim fixed resource during remove/rescan path Yinghai Lu
2015-07-27 23:30 ` [PATCH v3 48/51] PCI: Set resource to FIXED for lsi devices Yinghai Lu
2015-07-27 23:30 ` [PATCH v3 49/51] PCI, x86: Add pci=assign_pref_bars to re-allocate pref bars Yinghai Lu
2015-07-27 23:30 ` [PATCH v3 50/51] PCI: Introduce resource_disabled() Yinghai Lu
2015-07-27 23:30 ` [PATCH v3 51/51] PCI: Don't set flags to 0 when assign resource fail Yinghai Lu
2015-08-17 22:48 ` [PATCH v3 00/51] PCI: Resource allocation cleanup for v4.3 Bjorn Helgaas
2015-08-18 18:43 ` Yinghai Lu
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20150817235416.GS26431@google.com \
--to=bhelgaas@google.com \
--cc=akpm@linux-foundation.org \
--cc=benh@kernel.crashing.org \
--cc=davem@davemloft.net \
--cc=lenb@kernel.org \
--cc=linux-acpi@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-pci@vger.kernel.org \
--cc=linux@iam.tj \
--cc=rjw@rjwysocki.net \
--cc=wangyijing@huawei.com \
--cc=weiyang@linux.vnet.ibm.com \
--cc=yinghai@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome