From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1756003AbbHYSbj (ORCPT ); Tue, 25 Aug 2015 14:31:39 -0400 Received: from shards.monkeyblade.net ([149.20.54.216]:58743 "EHLO shards.monkeyblade.net" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1755732AbbHYSbh (ORCPT ); Tue, 25 Aug 2015 14:31:37 -0400 Date: Tue, 25 Aug 2015 11:31:36 -0700 (PDT) Message-Id: <20150825.113136.806044696899448612.davem@davemloft.net> To: ddaney.cavm@gmail.com Cc: netdev@vger.kernel.org, linux-kernel@vger.kernel.org, f.fainelli@gmail.com, david.daney@cavium.com, buytenh@wantstofly.org, grant.likely@secretlab.ca Subject: Re: [PATCH] phylib: Make PHYs children of their MDIO bus, not the bus' parent. From: David Miller In-Reply-To: <1440198963-20080-1-git-send-email-ddaney.cavm@gmail.com> References: <1440198963-20080-1-git-send-email-ddaney.cavm@gmail.com> X-Mailer: Mew version 6.7 on Emacs 24.5 / Mule 6.0 (HANACHIRUSATO) Mime-Version: 1.0 Content-Type: Text/Plain; charset=us-ascii Content-Transfer-Encoding: 7bit X-Greylist: Sender succeeded SMTP AUTH, not delayed by milter-greylist-4.5.12 (shards.monkeyblade.net [149.20.54.216]); Tue, 25 Aug 2015 11:31:37 -0700 (PDT) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org From: David Daney Date: Fri, 21 Aug 2015 16:16:03 -0700 > From: David Daney > > commit 18ee49ddb0d2 ("phylib: rename mii_bus::dev to mii_bus::parent") > changed the parent of PHY devices from the bus to the bus parent. > > Then, commit 4dea547fef1b ("phylib: rework to prepare for OF > registration of PHYs") moved the code into phy_device.c > > At this point, it is somewhat unclear why the change was seen as > necessary. But, when we look at the device model tree in > /sys/devices, it is clearly incorrect. The PHYs should be children of > their MDIO bus. > > Change the PHY's parent device to be the MDIO bus device. > > Cc: Lennert Buytenhek > Cc: Grant Likely > Signed-off-by: David Daney Applied, thanks.