From: Bjorn Andersson <bjorn.andersson@sonymobile.com>
To: Stephen Boyd <sboyd@codeaurora.org>
Cc: Andy Gross <agross@codeaurora.org>,
"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
"linux-arm-msm@vger.kernel.org" <linux-arm-msm@vger.kernel.org>,
"linux-arm-kernel@lists.infradead.org"
<linux-arm-kernel@lists.infradead.org>
Subject: Re: [PATCH 1/3] soc: qcom: smd: Represent channel layout in structures
Date: Mon, 31 Aug 2015 21:55:02 -0700 [thread overview]
Message-ID: <20150901045502.GB13472@usrtlx11787.corpusers.net> (raw)
In-Reply-To: <1441071594-15941-2-git-send-email-sboyd@codeaurora.org>
On Mon 31 Aug 18:39 PDT 2015, Stephen Boyd wrote:
> The rx and tx channel info are laid out in memory next to each
> other, and there are two types of channel info structures, byte
> based and word based. We have 4 pointers to these info
> structures, when we really only need two to point to the
> different types of structures. Encapsulate the byte based and word
> based tx/rx structures in a "full channel" structure that
> describes the layout of memory and reduces the number of pointers
> in the smd channel structure by two.
>
Saving the extra pointer doesn't feel like worth the change, but
representing the pair of info structs as one sounds like a reasonable
cleanup.
Reviewed-by: Bjorn Andersson <bjorn.andersson@sonymobile.com>
> Signed-off-by: Stephen Boyd <sboyd@codeaurora.org>
> ---
> drivers/soc/qcom/smd.c | 61 +++++++++++++++++++++++++++-----------------------
> 1 file changed, 33 insertions(+), 28 deletions(-)
>
> diff --git a/drivers/soc/qcom/smd.c b/drivers/soc/qcom/smd.c
> index edd9d9a37238..c16547b85e05 100644
> --- a/drivers/soc/qcom/smd.c
> +++ b/drivers/soc/qcom/smd.c
> @@ -65,7 +65,9 @@
> */
>
> struct smd_channel_info;
> +struct smd_full_channel_info;
I would have called this "smd_channel_info_pair"...
> struct smd_channel_info_word;
> +struct smd_full_channel_info_word;
>
Regards,
Bjorn
next prev parent reply other threads:[~2015-09-01 4:55 UTC|newest]
Thread overview: 11+ messages / expand[flat|nested] mbox.gz Atom feed top
2015-09-01 1:39 [PATCH 0/3] qcom smd big endian support Stephen Boyd
2015-09-01 1:39 ` [PATCH 1/3] soc: qcom: smd: Represent channel layout in structures Stephen Boyd
2015-09-01 4:55 ` Bjorn Andersson [this message]
2015-09-01 17:51 ` Stephen Boyd
2015-09-01 1:39 ` [PATCH 2/3] soc: qcom: smd: Use __iowrite32_copy() instead of open-coding it Stephen Boyd
2015-09-01 4:59 ` Bjorn Andersson
2015-09-01 18:03 ` Stephen Boyd
2015-09-01 20:30 ` Stephen Boyd
2015-09-01 1:39 ` [PATCH 3/3] soc: qcom: smd: Handle big endian CPUs Stephen Boyd
2015-09-01 5:06 ` Bjorn Andersson
2015-09-01 18:04 ` Stephen Boyd
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20150901045502.GB13472@usrtlx11787.corpusers.net \
--to=bjorn.andersson@sonymobile.com \
--cc=agross@codeaurora.org \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-arm-msm@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=sboyd@codeaurora.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®