From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1752027AbbIQRPf (ORCPT ); Thu, 17 Sep 2015 13:15:35 -0400 Received: from mail-yk0-f176.google.com ([209.85.160.176]:33219 "EHLO mail-yk0-f176.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751702AbbIQRPe (ORCPT ); Thu, 17 Sep 2015 13:15:34 -0400 Date: Thu, 17 Sep 2015 13:15:29 -0400 From: Tejun Heo To: James Bottomley Cc: "Michael S. Tsirkin" , Suman Anna , Ohad Ben-Cohen , linux-kernel@vger.kernel.org, virtualization@lists.linux-foundation.org, linux-scsi@vger.kernel.org, open-iscsi@googlegroups.com Subject: Re: DEFINE_IDA causing memory leaks? (was Re: [PATCH 1/2] virtio: fix memory leak of virtio ida cache layers) Message-ID: <20150917171529.GA15447@htj.duckdns.org> References: <1442449758-14594-1-git-send-email-s-anna@ti.com> <1442449758-14594-2-git-send-email-s-anna@ti.com> <20150917082425-mutt-send-email-mst@redhat.com> <1442499344.4073.0.camel@HansenPartnership.com> <20150917190538-mutt-send-email-mst@redhat.com> <1442508517.4073.13.camel@HansenPartnership.com> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <1442508517.4073.13.camel@HansenPartnership.com> User-Agent: Mutt/1.5.23 (2014-03-12) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Hello, On Thu, Sep 17, 2015 at 09:48:37AM -0700, James Bottomley wrote: > Well, there's an easy fix for that. We could have ida_remove() actually > free the bitmap and not cache it if it's the last layer. That way ida > would naturally empty and we wouldn't need a destructor. Tejun, would > that work? Yeah, that definitely is one way to go about it. It kinda muddles the purpose of ida_destroy() tho. I suppose we can rename it to idr_remove_all() and then do the same to idr. I'm not particularly objecting to all that but what's wrong with just calling idr_destroy() on exit paths? If missing the call in modules is an issue, maybe we can just annotate idr/ida with debugobj? Thanks. -- tejun