From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1752462AbbIWHBe (ORCPT ); Wed, 23 Sep 2015 03:01:34 -0400 Received: from mx1.redhat.com ([209.132.183.28]:44780 "EHLO mx1.redhat.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751622AbbIWHBc (ORCPT ); Wed, 23 Sep 2015 03:01:32 -0400 Date: Wed, 23 Sep 2015 15:01:21 +0800 From: Dave Young To: Baoquan He Cc: Minfei Huang , kexec@lists.infradead.org, linux-kernel@vger.kernel.org, "Eric W. Biederman" , akpm@linux-foundation.org, Minfei Huang Subject: Re: [PATCH] kexec: Add prefix "kexec" to output message Message-ID: <20150923070121.GC4394@dhcp-129-160.nay.redhat.com> References: <1442128512-32578-1-git-send-email-mnfhuang@gmail.com> <87fv2il0rq.fsf@x220.int.ebiederm.org> <20150914075056.GA13324@t440s.lenovo> <20150914084400.GA7953@localhost.localdomain> <20150915030804.GA7690@t440s.lenovo> <20150922160704.GA10225@dhcp-128-25.nay.redhat.com> <20150923013723.GA4394@dhcp-129-160.nay.redhat.com> <20150923024933.GB3166@dhcp-17-102.nay.redhat.com> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <20150923024933.GB3166@dhcp-17-102.nay.redhat.com> User-Agent: Mutt/1.5.22.1-rc1 (2013-10-16) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On 09/23/15 at 10:49am, Baoquan He wrote: > On 09/23/15 at 09:37am, Dave Young wrote: > > > > Hi, Dave. > > > > > > > > How about removing all of the prefix "crashkernel" in kexec_core. Thus > > > > we can be consistent with the output message prefix "kexec". > > > > > > Ping, any comment is appreciate and helpful. > > > > Remove "crashkernel" sounds not a proper way, it indicates crashkernel parsing > > messages. I have no idea what is the best way but below modification sounds better to me: > > > > kexec_core.c: > > > > #define pr_fmt(fmt) "[kexec_core] " fmt > > Also remove below prefix "Kexec:" > > pr_warn("Kexec: Memory allocation for saving cpu register states failed\n"); > > > > kexec.c: > > #define pr_fmt(fmt) "[kexec] " fmt > > > > kexec_file.c: > > #define pr_fmt(fmt) "[kexec_file] " fmt > > This is weird, user really don't need to know each file. I saw you added > a new file kexec_internal.h and all three files includes it. Why not doing > it there to make it the same as before? I personally do not like add these prefix to a header file. One prefix for a c file is better to me. But rethinking about the prefix, looks like there's a lot of other components using ":" so KBUILD_MODNAME ": " should be fine. Thanks Dave