From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1753952AbbIXUzU (ORCPT ); Thu, 24 Sep 2015 16:55:20 -0400 Received: from gum.cmpxchg.org ([85.214.110.215]:47009 "EHLO gum.cmpxchg.org" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1752523AbbIXUzT (ORCPT ); Thu, 24 Sep 2015 16:55:19 -0400 Date: Thu, 24 Sep 2015 16:55:09 -0400 From: Johannes Weiner To: Mel Gorman Cc: Andrew Morton , Rik van Riel , Vlastimil Babka , David Rientjes , Joonsoo Kim , Michal Hocko , Linux-MM , LKML Subject: Re: [PATCH 05/10] mm, page_alloc: Distinguish between being unable to sleep, unwilling to sleep and avoiding waking kswapd Message-ID: <20150924205509.GI3009@cmpxchg.org> References: <1442832762-7247-1-git-send-email-mgorman@techsingularity.net> <1442832762-7247-6-git-send-email-mgorman@techsingularity.net> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <1442832762-7247-6-git-send-email-mgorman@techsingularity.net> User-Agent: Mutt/1.5.23+102 (2ca89bed6448) (2014-03-12) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Mon, Sep 21, 2015 at 11:52:37AM +0100, Mel Gorman wrote: > @@ -119,10 +134,10 @@ struct vm_area_struct; > #define GFP_USER (__GFP_WAIT | __GFP_IO | __GFP_FS | __GFP_HARDWALL) > #define GFP_HIGHUSER (GFP_USER | __GFP_HIGHMEM) > #define GFP_HIGHUSER_MOVABLE (GFP_HIGHUSER | __GFP_MOVABLE) > -#define GFP_IOFS (__GFP_IO | __GFP_FS) > -#define GFP_TRANSHUGE (GFP_HIGHUSER_MOVABLE | __GFP_COMP | \ > - __GFP_NOMEMALLOC | __GFP_NORETRY | __GFP_NOWARN | \ > - __GFP_NO_KSWAPD) > +#define GFP_IOFS (__GFP_IO | __GFP_FS | __GFP_KSWAPD_RECLAIM) These are some really odd semantics to be given a name like that. GFP_IOFS was introduced as a short-hand for testing/setting/clearing these two bits at the same time, not to be used for allocations. In fact, the only user for allocations is lustre, and it's not at all obious why those sites shouldn't include __GFP_WAIT as well. Removing this definition altogether would probably be best.