From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1754806AbbI3I3H (ORCPT ); Wed, 30 Sep 2015 04:29:07 -0400 Received: from LGEAMRELO13.lge.com ([156.147.23.53]:33810 "EHLO lgeamrelo13.lge.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1753974AbbI3I3A (ORCPT ); Wed, 30 Sep 2015 04:29:00 -0400 X-Original-SENDERIP: 156.147.1.126 X-Original-MAILFROM: iamjoonsoo.kim@lge.com X-Original-SENDERIP: 10.177.222.138 X-Original-MAILFROM: iamjoonsoo.kim@lge.com Date: Wed, 30 Sep 2015 17:30:23 +0900 From: Joonsoo Kim To: Vlastimil Babka Cc: Andrew Morton , linux-kernel@vger.kernel.org, linux-mm@kvack.org, Mel Gorman , Rik van Riel , David Rientjes , Minchan Kim Subject: Re: [PATCH v2 5/9] mm/compaction: allow to scan nonmovable pageblock when depleted state Message-ID: <20150930083023.GC29589@js1304-P5Q-DELUXE> References: <1440382773-16070-1-git-send-email-iamjoonsoo.kim@lge.com> <1440382773-16070-6-git-send-email-iamjoonsoo.kim@lge.com> <560522A2.50609@suse.cz> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <560522A2.50609@suse.cz> User-Agent: Mutt/1.5.21 (2010-09-15) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Fri, Sep 25, 2015 at 12:32:02PM +0200, Vlastimil Babka wrote: > On 08/24/2015 04:19 AM, Joonsoo Kim wrote: > > [...] > > > > > Because we just allow freepage scanner to scan non-movable pageblock > > in very limited situation, more scanning events happen. But, allowing > > in very limited situation results in a very important benefit that > > memory isn't fragmented more than before. Fragmentation effect is > > measured on following patch so please refer it. > > AFAICS it's measured only for the whole series in the cover letter, no? Just to > be sure I didn't overlook something. It takes too much time so no measurement is done on every patch. I will try to measure it on at least this patch in next revision. > > > Signed-off-by: Joonsoo Kim > > --- > > include/linux/mmzone.h | 1 + > > mm/compaction.c | 27 +++++++++++++++++++++++++-- > > 2 files changed, 26 insertions(+), 2 deletions(-) > > > > diff --git a/include/linux/mmzone.h b/include/linux/mmzone.h > > index e13b732..5cae0ad 100644 > > --- a/include/linux/mmzone.h > > +++ b/include/linux/mmzone.h > > @@ -545,6 +545,7 @@ enum zone_flags { > > */ > > ZONE_FAIR_DEPLETED, /* fair zone policy batch depleted */ > > ZONE_COMPACTION_DEPLETED, /* compaction possiblity depleted */ > > + ZONE_COMPACTION_SCANALLFREE, /* scan all kinds of pageblocks */ > > "SCANALLFREE" is hard to read. Otherwise yeah, I agree scanning unmovable > pageblocks is necessary sometimes, and this seems to make a reasonable tradeoff. Good! I will think better name. Thanks.