From: Peter Zijlstra <peterz@infradead.org>
To: "Meyer, Mike" <Mike.Meyer@Teradata.com>
Cc: "linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
"mingo@redhat.com" <mingo@redhat.com>
Subject: Re: [PATCH] sched: fix task and run queue run_delay inconsistencies
Date: Thu, 1 Oct 2015 11:43:13 +0200 [thread overview]
Message-ID: <20151001094313.GA3281@worktop.programming.kicks-ass.net> (raw)
In-Reply-To: <20151001063732.GM2881@worktop.programming.kicks-ass.net>
On Thu, Oct 01, 2015 at 08:37:32AM +0200, Peter Zijlstra wrote:
> On Wed, Sep 30, 2015 at 08:28:41PM +0000, Meyer, Mike wrote:
> > Yes that will also address the issue.
> >
> > The reason I approached the way I did was to avoid adding code path to
> > the far more common uses of {en,de}queue_task() but I doubt anyone is
> > going to notice a difference with the addition of some register
> > save/restores and a compare in that path. Overall the code does
> > shrink with the alternative which is good.
>
> In most cases the flags should be compile time constants, and with the
> inline we can determine the branch at compile time, avoiding emitting
> that branch instruction entirely.
>
> But let me double check the asm for a few important sites.
It looks like the sites in the wakeup path do indeed not get any
additional conditionals.
> > My only comment is I am not sure about the naming of the flag
> > ENQUEUE_TEMP which implies (to me) the enqueue is temporary which
> > clearly it isn't. Maybe something like DEQUEUE_MOVE/ENQUEUE_MOVE
> > would be a bit more descriptive of the use case.
>
> Yes, I ran out of creative juices, let me attempt a better name once
> I've woken up a bit.
How about DEQUEUE_SAVE, ENQUEUE_RESTORE ? Ideally I'd wrap the whole
pattern into a helper but C isn't really supportive of pre+post patterns
like this.
next prev parent reply other threads:[~2015-10-01 9:43 UTC|newest]
Thread overview: 7+ messages / expand[flat|nested] mbox.gz Atom feed top
2015-09-23 0:37 Meyer, Mike
2015-09-30 15:44 ` Peter Zijlstra
2015-09-30 20:28 ` Meyer, Mike
2015-10-01 6:37 ` Peter Zijlstra
2015-10-01 9:43 ` Peter Zijlstra [this message]
2015-10-01 16:06 ` Meyer, Mike
2015-10-06 16:17 ` [tip:sched/core] sched/core: Fix task and run queue sched_info:: " tip-bot for Peter Zijlstra
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20151001094313.GA3281@worktop.programming.kicks-ass.net \
--to=peterz@infradead.org \
--cc=Mike.Meyer@Teradata.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@redhat.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome