From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1751637AbbJDQio (ORCPT ); Sun, 4 Oct 2015 12:38:44 -0400 Received: from mail-yk0-f173.google.com ([209.85.160.173]:36479 "EHLO mail-yk0-f173.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751453AbbJDQin (ORCPT ); Sun, 4 Oct 2015 12:38:43 -0400 Date: Sun, 4 Oct 2015 12:38:36 -0400 From: Tejun Heo To: Oleg Nesterov Cc: Andrew Morton , David Woodhouse , Felipe Balbi , Markus Pargmann , linux-kernel@vger.kernel.org, linux-mtd@lists.infradead.org Subject: Re: [PATCH 1/3] signal: turn dequeue_signal_lock() into kernel_dequeue_signal() Message-ID: <20151004163836.GA19652@htj.duckdns.org> References: <20151003181319.GA1036@redhat.com> <20151003181336.GA1054@redhat.com> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <20151003181336.GA1054@redhat.com> User-Agent: Mutt/1.5.24 (2015-08-30) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Sat, Oct 03, 2015 at 08:13:36PM +0200, Oleg Nesterov wrote: > 1. Rename dequeue_signal_lock() to kernel_dequeue_signal(). This > matches another "for kthreads only" kernel_sigaction() helper. > > 2. Remove the "tsk" and "mask" arguments, they are always current > and current->blocked. And it is simply wrong if tsk != current. > > 3. We could also remove the 3rd "siginfo_t *info" arg but it looks > potentially useful. However we can simplify the callers if we > change kernel_dequeue_signal() to accept info => NULL. > > 4. Remove _irqsave, it is never called from atomic context. > > Signed-off-by: Oleg Nesterov FWIW, looks good to me. Reviewed-by: Tejun Heo Thanks. -- tejun