From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1753176AbbJMPiA (ORCPT ); Tue, 13 Oct 2015 11:38:00 -0400 Received: from smtprelay0095.hostedemail.com ([216.40.44.95]:54174 "EHLO smtprelay.hostedemail.com" rhost-flags-OK-OK-OK-FAIL) by vger.kernel.org with ESMTP id S1752702AbbJMPh7 (ORCPT ); Tue, 13 Oct 2015 11:37:59 -0400 X-Session-Marker: 726F737465647440676F6F646D69732E6F7267 X-Spam-Summary: 2,0,0,,d41d8cd98f00b204,rostedt@goodmis.org,:::::::::::::::::,RULES_HIT:41:355:379:541:599:800:960:973:988:989:1260:1277:1311:1313:1314:1345:1359:1437:1515:1516:1518:1534:1541:1593:1594:1711:1730:1747:1777:1792:2393:2553:2559:2562:3138:3139:3140:3141:3142:3353:3622:3865:3866:3867:3870:3871:3874:5007:6119:6261:7875:7901:7904:10004:10400:10848:10967:11026:11232:11473:11658:11914:12296:12438:12517:12519:12555:12663:12740:13069:13161:13229:13255:13311:13357:21060:21080:21212,0,RBL:none,CacheIP:none,Bayesian:0.5,0.5,0.5,Netcheck:none,DomainCache:0,MSF:not bulk,SPF:fn,MSBL:0,DNSBL:none,Custom_rules:0:0:0 X-HE-Tag: oil46_61ff2bd106a3f X-Filterd-Recvd-Size: 2623 Date: Tue, 13 Oct 2015 11:37:50 -0400 From: Steven Rostedt To: AKASHI Takahiro Cc: catalin.marinas@arm.com, will.deacon@arm.com, jungseoklee85@gmail.com, olof@lixom.net, broonie@kernel.org, david.griego@linaro.org, linux-arm-kernel@lists.infradead.org, linux-kernel@vger.kernel.org Subject: Re: [PATCH v3 1/7] arm64: ftrace: adjust callsite addresses examined by stack tracer Message-ID: <20151013113750.0fdecd33@gandalf.local.home> In-Reply-To: <1444298504-10392-2-git-send-email-takahiro.akashi@linaro.org> References: <1444298504-10392-1-git-send-email-takahiro.akashi@linaro.org> <1444298504-10392-2-git-send-email-takahiro.akashi@linaro.org> X-Mailer: Claws Mail 3.12.0 (GTK+ 2.24.28; x86_64-pc-linux-gnu) MIME-Version: 1.0 Content-Type: text/plain; charset=US-ASCII Content-Transfer-Encoding: 7bit Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Thu, 8 Oct 2015 19:01:38 +0900 AKASHI Takahiro wrote: > extern int stack_tracer_enabled; > int > stack_trace_sysctl(struct ctl_table *table, int write, > diff --git a/kernel/trace/trace_stack.c b/kernel/trace/trace_stack.c > index b746399..30521ea 100644 > --- a/kernel/trace/trace_stack.c > +++ b/kernel/trace/trace_stack.c > @@ -105,7 +105,7 @@ check_stack(unsigned long ip, unsigned long *stack) > > /* Skip over the overhead of the stack tracer itself */ > for (i = 0; i < max_stack_trace.nr_entries; i++) { > - if (stack_dump_trace[i] == ip) > + if ((stack_dump_trace[i] + FTRACE_STACK_FRAME_OFFSET) == ip) > break; > } > > @@ -133,7 +133,8 @@ check_stack(unsigned long ip, unsigned long *stack) > for (; p < top && i < max_stack_trace.nr_entries; p++) { > if (stack_dump_trace[i] == ULONG_MAX) > break; > - if (*p == stack_dump_trace[i]) { > + if (*p == (stack_dump_trace[i] > + + FTRACE_STACK_FRAME_OFFSET)) { I'm fine with the patch, but this is one of those cases that I think the 80 column max limit produces uglier code than just going a little over. Or, we can add a helper variable in both locations: addr = stack_dump_trace[i] + FTRACE_STACK_FRAME_OFFSET; if (*p == addr) { gcc should be smart enough to optimize out the addr variable. -- Steve > stack_dump_trace[x] = stack_dump_trace[i++]; > this_size = stack_dump_index[x++] = > (top - p) * sizeof(unsigned long);