mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Greg KH <gregkh@linuxfoundation.org>
To: Sergei Shtylyov <sergei.shtylyov@cogentembedded.com>
Cc: linux-usb@vger.kernel.org, stern@rowland.harvard.edu,
	linux-kernel@vger.kernel.org
Subject: Re: [PATCH] ohci-pci: use PCI_DEVICE_SUB()
Date: Fri, 16 Oct 2015 23:39:42 -0700	[thread overview]
Message-ID: <20151017063942.GA14187@kroah.com> (raw)
In-Reply-To: <1541327.LNxLmfJ8uG@wasted.cogentembedded.com>

On Mon, Oct 12, 2015 at 08:31:55PM +0300, Sergei Shtylyov wrote:
> Toshiba  Portege 4000 quirk entry can be written shorter using the
> PCI_DEVICE_SUB() macro.
> 
> Signed-off-by: Sergei Shtylyov <sergei.shtylyov@cogentembedded.com>
> 
> ---
> The patch is against the 'usb-next' branch of Greg KH's 'usb.git' repo.
> 
>  drivers/usb/host/ohci-pci.c |    6 ++----
>  1 file changed, 2 insertions(+), 4 deletions(-)
> 
> Index: usb/drivers/usb/host/ohci-pci.c
> ===================================================================
> --- usb.orig/drivers/usb/host/ohci-pci.c
> +++ usb/drivers/usb/host/ohci-pci.c
> @@ -192,10 +192,8 @@ static const struct pci_device_id ohci_p
>  	},
>  	{
>  		/* Toshiba portege 4000 */
> -		.vendor		= PCI_VENDOR_ID_AL,
> -		.device		= 0x5237,
> -		.subvendor	= PCI_VENDOR_ID_TOSHIBA,
> -		.subdevice	= 0x0004,
> +		PCI_DEVICE_SUB(PCI_VENDOR_ID_AL, 0x5237,
> +			       PCI_VENDOR_ID_TOSHIBA, 0x0004),

But it's much less readable now, right?  Why make this change then?

sorry,

greg k-h

  reply	other threads:[~2015-10-17  6:39 UTC|newest]

Thread overview: 3+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2015-10-12 17:31 Sergei Shtylyov
2015-10-17  6:39 ` Greg KH [this message]
2015-10-17 12:17   ` Sergei Shtylyov

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20151017063942.GA14187@kroah.com \
    --to=gregkh@linuxfoundation.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-usb@vger.kernel.org \
    --cc=sergei.shtylyov@cogentembedded.com \
    --cc=stern@rowland.harvard.edu \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome