From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1751357AbbJYM1U (ORCPT ); Sun, 25 Oct 2015 08:27:20 -0400 Received: from mx1.redhat.com ([209.132.183.28]:58472 "EHLO mx1.redhat.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1750864AbbJYM1T (ORCPT ); Sun, 25 Oct 2015 08:27:19 -0400 Date: Sun, 25 Oct 2015 13:27:15 +0100 From: Jiri Olsa To: Arnaldo Carvalho de Melo Cc: Jiri Olsa , lkml , David Ahern , Ingo Molnar , Namhyung Kim , Peter Zijlstra , "Liang, Kan" Subject: Re: [PATCH 19/57] perf tools: Add attr_update event Message-ID: <20151025122715.GA26211@krava.brq.redhat.com> References: <1444992092-17897-1-git-send-email-jolsa@kernel.org> <1444992092-17897-20-git-send-email-jolsa@kernel.org> <20151019210004.GF3215@kernel.org> <20151022080146.GB29953@krava.redhat.com> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <20151022080146.GB29953@krava.redhat.com> User-Agent: Mutt/1.5.24 (2015-08-30) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Thu, Oct 22, 2015 at 10:01:46AM +0200, Jiri Olsa wrote: > On Mon, Oct 19, 2015 at 06:00:04PM -0300, Arnaldo Carvalho de Melo wrote: > > Em Fri, Oct 16, 2015 at 12:40:54PM +0200, Jiri Olsa escreveu: > > > It'll server as base event for additional event attributes > > > details, that are not part of the attr event. > > > > > > At the moment this event is just dummy one without specific > > > functionality. The type value will distinguish the update > > > event details. It comes in following patches. > > > > > > The idea for this event is to be extensible for any update > > > that attr event might need in the future. > > > > "Update"? Found it confusing, how about calling it "add event > > attribute", because that is what this is doing, adding attributes, like > > "unit" (Joules, MiB, nsec, etc), "scale", etc. > > well, we have PERF_RECORD_HEADER_ATTR event based on which the > event is created.. so PERF_RECORD_HEADER_ATTR_UPDATE seemed > like good choice.. anyway, how about: > > PERF_RECORD_ADD_EVENT_ATTR > PERF_RECORD_EVENT_ATTR > PERF_RECORD_EVENT_UPDATE choosing the PERF_RECORD_EVENT_UPDATE for next version.. jirka