From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1760704AbbLCQ1X (ORCPT ); Thu, 3 Dec 2015 11:27:23 -0500 Received: from mail-wm0-f54.google.com ([74.125.82.54]:35239 "EHLO mail-wm0-f54.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1760320AbbLCQ1V (ORCPT ); Thu, 3 Dec 2015 11:27:21 -0500 Date: Thu, 3 Dec 2015 17:27:18 +0100 From: Michal Hocko To: Geliang Tang Cc: Johannes Weiner , cgroups@vger.kernel.org, linux-mm@kvack.org, linux-kernel@vger.kernel.org Subject: Re: [PATCH] mm/memcontrol.c: use list_{first,next}_entry Message-ID: <20151203162718.GK9264@dhcp22.suse.cz> References: <9e62e3006561653fcbf0c49cf0b9c2b653a8ed0e.1449152124.git.geliangtang@163.com> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <9e62e3006561653fcbf0c49cf0b9c2b653a8ed0e.1449152124.git.geliangtang@163.com> User-Agent: Mutt/1.5.24 (2015-08-30) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Thu 03-12-15 22:16:55, Geliang Tang wrote: > To make the intention clearer, use list_{first,next}_entry instead > of list_entry. Does this really help readability? This function simply uncharges the given list of pages. Why cannot we simply use list_for_each_entry instead... > Signed-off-by: Geliang Tang > --- > mm/memcontrol.c | 9 +++------ > 1 file changed, 3 insertions(+), 6 deletions(-) > > diff --git a/mm/memcontrol.c b/mm/memcontrol.c > index 79a29d5..a6301ea 100644 > --- a/mm/memcontrol.c > +++ b/mm/memcontrol.c > @@ -5395,16 +5395,12 @@ static void uncharge_list(struct list_head *page_list) > unsigned long nr_file = 0; > unsigned long nr_huge = 0; > unsigned long pgpgout = 0; > - struct list_head *next; > struct page *page; > > - next = page_list->next; > + page = list_first_entry(page_list, struct page, lru); > do { > unsigned int nr_pages = 1; > > - page = list_entry(next, struct page, lru); > - next = page->lru.next; > - > VM_BUG_ON_PAGE(PageLRU(page), page); > VM_BUG_ON_PAGE(page_count(page), page); > > @@ -5440,7 +5436,8 @@ static void uncharge_list(struct list_head *page_list) > page->mem_cgroup = NULL; > > pgpgout++; > - } while (next != page_list); > + } while (!list_is_last(&page->lru, page_list) && > + (page = list_next_entry(page, lru))); > > if (memcg) > uncharge_batch(memcg, pgpgout, nr_anon, nr_file, > -- > 2.5.0 > -- Michal Hocko SUSE Labs