From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1754865AbbLJPgI (ORCPT ); Thu, 10 Dec 2015 10:36:08 -0500 Received: from bombadil.infradead.org ([198.137.202.9]:42982 "EHLO bombadil.infradead.org" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751932AbbLJPgG (ORCPT ); Thu, 10 Dec 2015 10:36:06 -0500 Date: Thu, 10 Dec 2015 07:35:40 -0800 From: Christoph Hellwig To: Josh Poimboeuf Cc: Jens Axboe , Geliang Tang , "Paul E. McKenney" , Jan Kara , Josef Bacik , Josh Triplett , Seth Jennings , Jiri Kosina , Vojtech Pavlik , Pablo Neira Ayuso , Patrick McHardy , Jozsef Kadlecsik , "David S. Miller" , live-patching@vger.kernel.org, netfilter-devel@vger.kernel.org, coreteam@netfilter.org, netdev@vger.kernel.org, linux-block@vger.kernel.org, linux-kernel@vger.kernel.org Subject: Re: [PATCH 1/4] list: introduce list_is_first() Message-ID: <20151210153540.GA27533@infradead.org> References: <305feb971ae11e192f35f25d66bb7b2e28e06c39.1449755818.git.geliangtang@163.com> <566995EA.80509@kernel.dk> <20151210152357.GG29872@treble.redhat.com> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <20151210152357.GG29872@treble.redhat.com> User-Agent: Mutt/1.5.23 (2014-03-12) X-SRS-Rewrite: SMTP reverse-path rewritten from by bombadil.infradead.org See http://www.infradead.org/rpr.html Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Thu, Dec 10, 2015 at 09:23:57AM -0600, Josh Poimboeuf wrote: > Personally I would disagree. Something like: > > if (list_is_first(&rq->queuelist, &nd->queue)) > > is much more readable to me than: > > if (rq->queuelist.prev == &nd->queue) > > The first one takes no effort for me -- it's almost English. While the > second one takes me a few seconds (and some precious brain cycles) to > decipher. > > Maybe whether it's readable depends on how many years you've been > looking at the pattern. But IMHO we shouldn't make "having x # of years > staring at kernel code" a prerequisite for being able to read kernel > code. I think understanding the list.h semantics is a requirement for writing (or reading) non-trivial kernel code.