From: Sanidhya Solanki <jpage.lkml@gmail.com>
To: Jason Cooper <jason@lakedaemon.net>
Cc: gregkh@linuxfoundation.org, mathieu.poirier@linaro.org,
deepa.kernel@gmail.com, brcnakalin@gmail.com,
vatikaharlalka@gmail.com, sudipm.mukherjee@gmail.com,
devel@driverdev.osuosl.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH] Staging: Skein: Moved macros from skein_block.c to header file.
Date: Mon, 14 Dec 2015 19:08:08 -0500 [thread overview]
Message-ID: <20151214190808.364f1c9b@gmail.com> (raw)
In-Reply-To: <20151208130905.GX6520@io.lakedaemon.net>
The original code defined macros in the source code, making it
harder to read. Moved them to the header file, as per the TODO file.
Updated the TODO file.
Signed-off-by: Sanidhya Solanki <jpage.lkml@gmail.com>
---
drivers/staging/skein/TODO | 1 -
drivers/staging/skein/skein_block.c | 6 ------
drivers/staging/skein/skein_block.h | 7 +++++++
3 files changed, 7 insertions(+), 7 deletions(-)
diff --git a/drivers/staging/skein/TODO b/drivers/staging/skein/TODO
index cd3508d..e3de0c7 100644
--- a/drivers/staging/skein/TODO
+++ b/drivers/staging/skein/TODO
@@ -1,6 +1,5 @@
skein/threefish TODO
- - move macros into appropriate header files
- add / pass test vectors
- module support
diff --git a/drivers/staging/skein/skein_block.c b/drivers/staging/skein/skein_block.c
index 45b4732..2120392 100644
--- a/drivers/staging/skein/skein_block.c
+++ b/drivers/staging/skein/skein_block.c
@@ -26,12 +26,6 @@
#define SKEIN_LOOP 001 /* default: unroll 256 and 512, but not 1024 */
#endif
-#define BLK_BITS (WCNT * 64) /* some useful definitions for code here */
-#define KW_TWK_BASE (0)
-#define KW_KEY_BASE (3)
-#define ks (kw + KW_KEY_BASE)
-#define ts (kw + KW_TWK_BASE)
-
#ifdef SKEIN_DEBUG
#define debug_save_tweak(ctx) \
{ \
diff --git a/drivers/staging/skein/skein_block.h b/drivers/staging/skein/skein_block.h
index 9d40f4a..0fd4bfe 100644
--- a/drivers/staging/skein/skein_block.h
+++ b/drivers/staging/skein/skein_block.h
@@ -7,6 +7,13 @@
** This algorithm and source code is released to the public domain.
**
************************************************************************/
+
+#define BLK_BITS (WCNT * 64) /* some useful definitions for code here */
+#define KW_TWK_BASE (0)
+#define KW_KEY_BASE (3)
+#define ks (kw + KW_KEY_BASE)
+#define ts (kw + KW_TWK_BASE)
+
#ifndef _SKEIN_BLOCK_H_
#define _SKEIN_BLOCK_H_
--
2.5.0
next prev parent reply other threads:[~2015-12-15 4:09 UTC|newest]
Thread overview: 7+ messages / expand[flat|nested] mbox.gz Atom feed top
2015-12-08 2:37 Sanidhya Solanki
2015-12-08 13:09 ` Jason Cooper
2015-12-15 0:08 ` Sanidhya Solanki [this message]
2015-12-15 14:55 ` Mathieu Poirier
2015-12-15 22:20 ` Sanidhya Solanki
2015-12-17 7:16 ` Sudip Mukherjee
2016-01-29 6:34 ` Greg KH
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20151214190808.364f1c9b@gmail.com \
--to=jpage.lkml@gmail.com \
--cc=brcnakalin@gmail.com \
--cc=deepa.kernel@gmail.com \
--cc=devel@driverdev.osuosl.org \
--cc=gregkh@linuxfoundation.org \
--cc=jason@lakedaemon.net \
--cc=linux-kernel@vger.kernel.org \
--cc=mathieu.poirier@linaro.org \
--cc=sudipm.mukherjee@gmail.com \
--cc=vatikaharlalka@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome