From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S965215AbbLOMOF (ORCPT ); Tue, 15 Dec 2015 07:14:05 -0500 Received: from mail-pf0-f178.google.com ([209.85.192.178]:36387 "EHLO mail-pf0-f178.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S964921AbbLOMOD (ORCPT ); Tue, 15 Dec 2015 07:14:03 -0500 Date: Tue, 15 Dec 2015 21:13:20 +0900 From: Namhyung Kim To: Arnaldo Carvalho de Melo Cc: Jiri Olsa , Ingo Molnar , Peter Zijlstra , LKML , David Ahern , Steven Rostedt , Frederic Weisbecker , Andi Kleen , Wang Nan Subject: Re: [PATCH 6/6] perf tools: Try to show pretty printed output for dynamic sort keys Message-ID: <20151215121320.GB12003@danjae.kornet> References: <1450107973-2447-1-git-send-email-namhyung@kernel.org> <1450107973-2447-7-git-send-email-namhyung@kernel.org> <20151215090329.GE16565@krava.brq.redhat.com> <20151215103637.GZ6843@kernel.org> MIME-Version: 1.0 Content-Type: text/plain; charset=utf-8 Content-Disposition: inline In-Reply-To: <20151215103637.GZ6843@kernel.org> User-Agent: Mutt/1.5.24 (2015-08-30) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Tue, Dec 15, 2015 at 07:36:37AM -0300, Arnaldo Carvalho de Melo wrote: > Em Tue, Dec 15, 2015 at 10:03:29AM +0100, Jiri Olsa escreveu: > > On Tue, Dec 15, 2015 at 12:46:13AM +0900, Namhyung Kim wrote: > > > Each tracepoint event has format string for print to improve > > > readability. Try to parse the output and match the field name. If it > > > finds one, use that for the result. If not, fallbacks to the original > > > output. > > > > > > For example, sort on kmem:kmalloc.gfp_flags looks like below: > > > (Note: libtraceevent plugins are not installed on my system. They might > > > affect the output below) > > > > > > Before: > > > # Overhead Command gfp_flags > > > # ........ ....... .......... > > > # > > > 99.89% perf 32848 > > > 0.06% sleep 208 > > > 0.03% perf 32976 > > > 0.01% perf 208 > > > > > > After: > > > # Overhead Command gfp_flags > > > # ........ ....... ................... > > > # > > > 99.89% perf GFP_NOFS|GFP_ZERO > > > 0.06% sleep GFP_KERNEL > > > 0.03% perf GFP_KERNEL|GFP_ZERO > > > 0.01% perf GFP_KERNEL > > > > hum, maybe we want some way to switch back to numbers? OK. Maybe something like 'kmem:kmalloc.gfp_flags/raw' ? > > Or remove repetitive stuff like GFP_? I guess this was done already for > perf kmem? Right, perf-kmem did that. But perf-report is more general and it's hard to handle every field this way. Also I think it might be better to keep the output as perf-script. Thanks, Namhyung