From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1754378AbbLTO6r (ORCPT ); Sun, 20 Dec 2015 09:58:47 -0500 Received: from mx1.redhat.com ([209.132.183.28]:54910 "EHLO mx1.redhat.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1752955AbbLTO6q (ORCPT ); Sun, 20 Dec 2015 09:58:46 -0500 Date: Sun, 20 Dec 2015 15:58:42 +0100 From: Jiri Olsa To: Namhyung Kim Cc: Arnaldo Carvalho de Melo , Ingo Molnar , Peter Zijlstra , LKML , David Ahern , Steven Rostedt , Frederic Weisbecker , Andi Kleen , Wang Nan Subject: Re: [PATCH 08/10] perf tools: Add --raw-trace option Message-ID: <20151220145842.GA18893@krava.brq.redhat.com> References: <1450193743-4409-1-git-send-email-namhyung@kernel.org> <1450193743-4409-9-git-send-email-namhyung@kernel.org> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <1450193743-4409-9-git-send-email-namhyung@kernel.org> User-Agent: Mutt/1.5.24 (2015-08-30) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Wed, Dec 16, 2015 at 12:35:41AM +0900, Namhyung Kim wrote: > The --raw-trace option is to prevent pretty printing by event's > print_fmt or plugin. Besides that, each dynamic sort key now receives > 'raw' suffix separated by '/' to apply the raw trace to a specific > field. > > $ perf report -s comm,kmem:kmalloc.gfp_flags > ... > # Overhead Command gfp_flags > # ........ ....... ................... > # > 99.89% perf GFP_NOFS|GFP_ZERO > 0.06% sleep GFP_KERNEL > 0.03% perf GFP_KERNEL|GFP_ZERO > 0.01% perf GFP_KERNEL > > Now > > $ perf report -s comm,kmem:kmalloc.gfp_flags --raw-trace > or > $ perf report -s comm,kmem:kmalloc.gfp_flags/raw > ... > # Overhead Command gfp_flags > # ........ ....... .......... > # > 99.89% perf 32848 > 0.06% sleep 208 > 0.03% perf 32976 > 0.01% perf 208 > > Suggested-by: Jiri Olsa > Cc: Steven Rostedt > Signed-off-by: Namhyung Kim I think the default is good with the 'trace' sort key as it is now: $ ./perf report -s trace 27.01% offlineimap:17701 [120] S ==> swapper/1:0 [120] 27.00% swapper/1:0 [120] R ==> offlineimap:17701 [120] But for '--raw-trace' option rather than displaying fields in the '=' notation: $ ./perf report -s trace --raw-trace 27.01% prev_comm=offlineimap prev_pid=17701 prev_prio=120 prev_state=1 next_comm=swapper/1 next_pid=0 next_prio=120 27.00% prev_comm=swapper/1 prev_pid=0 prev_prio=120 prev_state=0 next_comm=offlineimap next_pid=17701 next_prio=120 it would be more readable to register all available columns as is possible to do now with: $ ./perf report -s prev_comm,prev_pid,prev_prio,prev_state,next_comm,next_pid,next_prio Overhead prev_comm prev_pid prev_prio prev_state next_comm next_pid next_prio 27.01% offlineimap 17701 120 1 swapper/1 0 120 27.00% swapper/1 0 120 0 offlineimap 17701 120 it would be default output for 'perf report -s trace --raw-trace' command how about that? thanks, jirka