From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1752415AbcAMPnW (ORCPT ); Wed, 13 Jan 2016 10:43:22 -0500 Received: from mail-wm0-f65.google.com ([74.125.82.65]:34774 "EHLO mail-wm0-f65.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1750955AbcAMPnV (ORCPT ); Wed, 13 Jan 2016 10:43:21 -0500 Date: Wed, 13 Jan 2016 16:43:22 +0100 From: Daniel Vetter To: Geliang Tang Cc: David Airlie , linux-kernel@vger.kernel.org, dri-devel@lists.freedesktop.org Subject: Re: [PATCH 3/5] drm/sysfs: use kobj_to_dev() Message-ID: <20160113154322.GV19130@phenom.ffwll.local> Mail-Followup-To: Geliang Tang , David Airlie , linux-kernel@vger.kernel.org, dri-devel@lists.freedesktop.org References: <60dcf3fb69ec74bd57026ae434bd06514d699044.1452696179.git.geliangtang@163.com> <3fea991541fbfc4ffece2c174adeb02cb9436c90.1452696179.git.geliangtang@163.com> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <3fea991541fbfc4ffece2c174adeb02cb9436c90.1452696179.git.geliangtang@163.com> X-Operating-System: Linux phenom 4.3.0-1-amd64 User-Agent: Mutt/1.5.24 (2015-08-30) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Wed, Jan 13, 2016 at 10:48:41PM +0800, Geliang Tang wrote: > Use kobj_to_dev() instead of open-coding it. > > Signed-off-by: Geliang Tang Merged to drm-misc, thanks. -Daniel > --- > drivers/gpu/drm/drm_sysfs.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/drivers/gpu/drm/drm_sysfs.c b/drivers/gpu/drm/drm_sysfs.c > index 0ca6410..d503f8e 100644 > --- a/drivers/gpu/drm/drm_sysfs.c > +++ b/drivers/gpu/drm/drm_sysfs.c > @@ -240,7 +240,7 @@ static ssize_t edid_show(struct file *filp, struct kobject *kobj, > struct bin_attribute *attr, char *buf, loff_t off, > size_t count) > { > - struct device *connector_dev = container_of(kobj, struct device, kobj); > + struct device *connector_dev = kobj_to_dev(kobj); > struct drm_connector *connector = to_drm_connector(connector_dev); > unsigned char *edid; > size_t size; > -- > 2.5.0 > > > _______________________________________________ > dri-devel mailing list > dri-devel@lists.freedesktop.org > http://lists.freedesktop.org/mailman/listinfo/dri-devel -- Daniel Vetter Software Engineer, Intel Corporation http://blog.ffwll.ch