From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S934141AbcATO3i (ORCPT ); Wed, 20 Jan 2016 09:29:38 -0500 Received: from relay-b01.edpnet.be ([212.71.1.221]:44372 "EHLO relay-b01.edpnet.be" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S932839AbcATO30 (ORCPT ); Wed, 20 Jan 2016 09:29:26 -0500 X-Greylist: delayed 931 seconds by postgrey-1.27 at vger.kernel.org; Wed, 20 Jan 2016 09:29:25 EST X-ASG-Debug-ID: 1453299229-0a7ff56009590b0001-xx1T2L X-Barracuda-Envelope-From: dev.kurt@vandijck-laurijssen.be X-Barracuda-Effective-Source-IP: 85.234.200.85.static.edpnet.net[85.234.200.85] X-Barracuda-Apparent-Source-IP: 85.234.200.85 Date: Wed, 20 Jan 2016 15:11:51 +0100 From: Kurt Van Dijck To: Michael Grzeschik Cc: mkl@pengutronix.de, wg@grandegger.com, linux-can@vger.kernel.org, netdev@vger.kernel.org, linux-kernel@vger.kernel.org, kernel@pengutronix.de Subject: Re: [PATCH v2] can: c_can: add xceiver enable/disable support Message-ID: <20160120141151.GA626@airbook.eia.lan> X-ASG-Orig-Subj: Re: [PATCH v2] can: c_can: add xceiver enable/disable support Mail-Followup-To: Michael Grzeschik , mkl@pengutronix.de, wg@grandegger.com, linux-can@vger.kernel.org, netdev@vger.kernel.org, linux-kernel@vger.kernel.org, kernel@pengutronix.de References: <1453297443-23279-1-git-send-email-m.grzeschik@pengutronix.de> MIME-Version: 1.0 Content-Type: text/plain; charset=utf-8 Content-Disposition: inline In-Reply-To: <1453297443-23279-1-git-send-email-m.grzeschik@pengutronix.de> User-Agent: Mutt/1.5.22 (2013-10-16) X-Barracuda-Connect: 85.234.200.85.static.edpnet.net[85.234.200.85] X-Barracuda-Start-Time: 1453299229 X-Barracuda-URL: https://212.71.1.221:443/cgi-mod/mark.cgi X-Barracuda-Scan-Msg-Size: 880 X-Barracuda-BRTS-Status: 1 X-Barracuda-Bayes: INNOCENT GLOBAL 0.5000 1.0000 0.0000 X-Barracuda-Spam-Score: 0.00 X-Barracuda-Spam-Status: No, SCORE=0.00 using global scores of TAG_LEVEL=1000.0 QUARANTINE_LEVEL=1000.0 KILL_LEVEL=9.0 tests=BSF_SC0_MISMATCH_TO X-Barracuda-Spam-Report: Code version 3.2, rules version 3.2.3.26297 Rule breakdown below pts rule name description ---- ---------------------- -------------------------------------------------- 0.00 BSF_SC0_MISMATCH_TO Envelope rcpt doesn't match header Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org > diff --git a/drivers/net/can/c_can/c_can.c b/drivers/net/can/c_can/c_can.c > index f91b094..0723aeb 100644 > --- a/drivers/net/can/c_can/c_can.c > +++ b/drivers/net/can/c_can/c_can.c > @@ -1263,6 +1271,10 @@ int register_c_can_dev(struct net_device *dev) > */ > pinctrl_pm_select_sleep_state(dev->dev.parent); > > + priv->reg_xceiver = devm_regulator_get(priv->device, "xceiver"); I assume "xceiver" is the shorter name for "transceiver"? In that case, I suggest changing the devicetree label to "transceiver". It would become a mess if different drivers use different names. I see no real benefit for naming it "xceiver". "trx" is even shorter :-) See also http://www.acronymfinder.com/TRX.html The internals, like variable names, do not really matter here. I haven't looked at other driver, yet the argument still stands. Kind regards, Kurt