From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S966273AbcA1BOR (ORCPT ); Wed, 27 Jan 2016 20:14:17 -0500 Received: from mailout1.samsung.com ([203.254.224.24]:42522 "EHLO mailout1.samsung.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S965366AbcA1BON (ORCPT ); Wed, 27 Jan 2016 20:14:13 -0500 X-AuditID: cbfee690-f79646d000001316-9a-56a96b5f08ad Date: Thu, 28 Jan 2016 10:14:07 +0900 From: Andi Shyti To: Javier Martinez Canillas Cc: linux-kernel@vger.kernel.org, Kukjin Kim , rtc-linux@googlegroups.com, Chanwoo Choi , Alexandre Belloni , Krzysztof Kozlowski , Laxman Dewangan , linux-samsung-soc@vger.kernel.org, Arnd Bergmann , Olof Johansson , linux-arm-kernel@lists.infradead.org Subject: Re: [PATCH v4 00/10] rtc: max77686: Extend driver and add max77802 support Message-id: <20160128011407.GC20739@samsunx.samsung> References: <1453865806-4661-1-git-send-email-javier@osg.samsung.com> MIME-version: 1.0 Content-type: text/plain; charset=us-ascii Content-disposition: inline In-reply-to: <1453865806-4661-1-git-send-email-javier@osg.samsung.com> User-Agent: Mutt/1.5.24 (2015-08-30) X-Brightmail-Tracker: H4sIAAAAAAAAA+NgFrrCIsWRmVeSWpSXmKPExsWyRsSkSDc+e2WYwfSP6hYd1xYzWfyddIzd 4vqX56wWb96uYbJ4/cLQov/xa2aLpftWs1hsenyN1eLyrjlsFjPO72OyOHX9M5vF/s4ORgce j9+/JjF6PNl0kdFjz8STbB6bVnWyeWxeUu9x5UQTq0dv8zs2jy39d9k9+rasYvT4vEkugCuK yyYlNSezLLVI3y6BK6Pp/ULGgnN6FbeunmRtYDym2sXIySEhYCLxZ+lXJghbTOLCvfVsXYxc HEICKxgllh7dxQRTdGvrRCaIxFJGiTmHpkI5HxklNu/YzgJSxSKgKtHVf4QZxGYT0JRouv2D DcQWETCV+LX2BStIA7PAcmaJo1v3g40VFgiVOHPwBlgzL9CK2w/+M4LYQgKuEgsvXGCFiAtK /Jh8D6yGWUBLYv3O40wQtrTEo78z2EFsTgE3iQe77gDZHByiAioSrw7Wg+ySEJjLIfG1/w7U cQIS3yYfYgGpkRCQldh0gBniM0mJgytusExgFJuFZNssJNtmIdm2gJF5FaNoakFyQXFSepGJ XnFibnFpXrpecn7uJkZgZJ/+92zCDsZ7B6wPMQpwMCrx8DJErQwTYk0sK67MPcRoCnTFRGYp 0eR8YPrIK4k3NDYzsjA1MTU2Mrc0UxLnfS31M1hIID2xJDU7NbUgtSi+qDQntfgQIxMHp1QD Y3S543X+j8LHvYuPRUlEsyWIcFu4HA1fsDN6VZFWZ8xvTiWD+3smPUh8LbXjRoN49NTHtqVa rqfMjWI39KYamkb4HRBX+GoTZWChsPRBUvaqCt7c8tMfN2eu1t56t1Z4VujFfTXvg0z3FE4v f7479OyEI5Pzdc/FmmmW2pxKDjJfz2Q1ZVWrEktxRqKhFnNRcSIATobJ3ecCAAA= X-Brightmail-Tracker: H4sIAAAAAAAAA+NgFlrIKsWRmVeSWpSXmKPExsVy+t9jAd347JVhBsv3KVp0XFvMZPF30jF2 i+tfnrNavHm7hsni9QtDi/7Hr5ktlu5bzWKx6fE1VovLu+awWcw4v4/J4tT1z2wW+zs7GB14 PH7/msTo8WTTRUaPPRNPsnlsWtXJ5rF5Sb3HlRNNrB69ze/YPLb032X36NuyitHj8ya5AK6o BkabjNTElNQihdS85PyUzLx0WyXv4HjneFMzA0NdQ0sLcyWFvMTcVFslF58AXbfMHKC7lRTK EnNKgUIBicXFSvp2mCaEhrjpWsA0Ruj6hgTB9RgZoIGENYwZTe8XMhac06u4dfUkawPjMdUu Rk4OCQETiVtbJzJB2GISF+6tZ+ti5OIQEljKKDHn0FQmCOcjo8TmHdtZQKpYBFQluvqPMIPY bAKaEk23f7CB2CICphK/1r5gBWlgFljOLHF0636wscICoRJnDt4Aa+YFWnf7wX9GEFtIwFVi 4YULrBBxQYkfk++B1TALaEms33mcCcKWlnj0dwY7iM0p4CbxYNcdIJuDQ1RAReLVwfoJjAKz kHTPQtI9C0n3AkbmVYwSqQXJBcVJ6blGeanlesWJucWleel6yfm5mxjByeOZ9A7Gw7vcDzEK cDAq8fAyRK0ME2JNLCuuzD3EKMHBrCTCOysZKMSbklhZlVqUH19UmpNafIjRFBggE5mlRJPz gYktryTe0NjEzMjSyNzQwsjYXEmcd9+lyDAhgfTEktTs1NSC1CKYPiYOTqkGxqYjXaf3b98d JVJ9ONFR692noK9yG4uv3d0kdfxSUECU7l2+E59z1v/lZixUnWxnPeX76ZuhUntv2ytudZ1x h680a0nmpIPPtdf4GUXv2PDyiG6mrXSYwl3eg+9mfxVduvHt3V3vVnxxNXpc0H7Z5zL7f3Oe Bd3tFypTjhyrMzAS+sKkxSi/dIMSS3FGoqEWc1FxIgAQzkxhNAMAAA== DLP-Filter: Pass X-MTR: 20000000000000000@CPGS X-CFilter-Loop: Reflected Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Hi Javier, In case I forgot any, for the whole patchset, Reviewed-by: Andi Shyti Andi On Wed, Jan 27, 2016 at 12:36:36AM -0300, Javier Martinez Canillas wrote: > Hello, > > On a recent disussion [0] with Krzysztof Kozlowski and Laxman Dewangan, > we came to the conclusion that the max77686 and max77802 RTC are almost > the same with only a few differences so there shouldn't be two separate > drivers and is better to extend max77686 driver and delete rtc-max77802. > > By making the driver more generic, other RTC IP blocks from Maxim PMICs > could be supported as well like the max77620. > > This is a v4 of a series that do this, that address issues pointed out > in the latest version. The v1, v2 and v3 can be found at [1], [2], [3]. > > I've tested this patch-set on an Exynos5800 Peach Pi Chromebook that has > a max77802 PMIC and the RTC was working correctly. Krzysztof Kozlowski > tested v3 on an max77686 but this version only has cosmetic changes so > it should not cause any functionality changes. > > [0]: http://www.spinics.net/lists/devicetree/msg110348.html > [1]: https://lwn.net/Articles/672568/ > [2]: https://lkml.org/lkml/2016/1/25/767 > [3]: https://lkml.org/lkml/2016/1/26/787 > > Changes in v4: > - Add Andi Shyti's Reviewed-by to patch #1. > - Add Andi Shyti's Reviewed-by to patch #2. > - Add Andi Shyti's Reviewed-by to patch #3. > - Add Andi Shyti's Reviewed-by to patch #4. > - Add Krzysztof Kozlowski's Reviewed-by and Tested-by tags to patch #4. > - Add Krzysztof Kozlowski's Reviewed-by and Tested-by tags to patch #5. > - Add Krzysztof Kozlowski's Tested-by tag to patch #6. > - Add Andi Shyti's Reviewed-by tag to patch #6. > - Reverse alarm enable reg check logic. Suggeted by Krzysztof Kozlowski. > - Return early to avoid an else statement. Suggested by Andi Shyti. > - Use dev_err() instead of dev_warn() and change message. > Suggested by Krzysztof Kozlowski and Andi Shyti. > - Change subject line and commit message of patch #7. > - Removed Laxman Dewangan's Acked-by tag since the patch changed. > - Add Krzysztof Kozlowski's Tested-by tag to patch #8. > - Add Andi Shyti's Reviewed-by tag to patch #8. > > Changes in v3: > - Add Krzysztof Kozlowski's Reviewed-by and Tested-by to patch #1. > - Add Laxman Dewangan's Acked-by tag to patch #1. > - Add Krzysztof Kozlowski's Tested-by tag to patch #2. > - Add Laxman Dewangan's Acked-by tag to patch #2. > - Use ARRAY_SIZE() in all places. Suggested by Laxman Dewangan. > - Add Krzysztof Kozlowski's Tested-by tag to patch #3. > - Add Laxman Dewangan's Acked-by tag to patch #3. > - Fix max77686 delay. Suggested by Krzysztof Kozlowski. > - Assign mask to u8 instead of int. Suggested by Krzysztof Kozlowski. > - Add Laxman Dewangan's Acked-by tag to patch #4. > - Add Laxman Dewangan's Acked-by tag to patch #5. > - Add Laxman Dewangan's Acked-by tag to patch #6. > - Add Laxman Dewangan's Acked-by tag to patch #7. > - Add Laxman Dewangan's Acked-by tag to patch #8. > > Changes in v2: > - Add Krzysztof Kozlowski's Reviewed-by tag to patch #2. > - Add Krzysztof Kozlowski's Reviewed-by tag to patch #3. > - Fix typo error in changelog. Suggested by Krzysztof Kozlowski. > - Add a max77686 prefix to rtc_driver_data. Suggested by Krzysztof Kozlowski. > - Comment about the .delay and .mask fields. Suggested by Krzysztof Kozlowski. > - Change .mask type to u8. Suggested by Krzysztof Kozlowski. > - Make .drv_data field const. Suggested by Krzysztof Kozlowski. > - Don't cast to drop const on .drv_data asign. Suggested by Krzysztof Kozlowski. > - Use platform_get_device_id() macro. Suggested by Krzysztof Kozlowski. > - Rename rtc_reg to max77686_rtc_reg_offset. Suggested by Krzysztof Kozlowski. > - Comment what's mapped by max77686_map. Suggested by Krzysztof Kozlowski. > - Use max77686_map array indexes in init. Suggested by Krzysztof Kozlowski. > - Remove REG_RTC_UPDATE1 since is not used by neither max77686 nor max77802. > - Add a MAX77802 prefix to ALARM_ENABLE_VALUE. Suggested by Krzysztof Kozlowski. > - Rename .rtcae to .alarm_enable_reg and .rtcrm to .separate_i2c_addr. > Suggested by Krzysztof Kozlowski. > - Don't use func and LINE in error messages. Suggested by Krzysztof Kozlowski. > - Remove REG_RTC_AE2 since is not used by neither max77686 nor max77802. > - Check if REG_RTC_AE1 has a valid address before accessing it. > - Add Krzysztof Kozlowski's Reviewed-by tag to patch #8. > - Add Krzysztof Kozlowski's Reviewed-by tag to patch #9. > - Add Krzysztof Kozlowski's Reviewed-by tag to patch #10. > > Javier Martinez Canillas (10): > rtc: max77686: Fix max77686_rtc_read_alarm() return value > rtc: max77686: Use ARRAY_SIZE() instead of current array length > rtc: max77686: Use usleep_range() instead of msleep() > rtc: max77686: Use a driver data struct instead hard-coded values > rtc: max77686: Add an indirection level to access RTC registers > rtc: max77686: Add max77802 support > rtc: max77686: Fix unsupported year message > rtc: Remove Maxim 77802 driver > ARM: exynos_defconfig: Remove MAX77802 RTC Kconfig symbol > ARM: multi_v7_defconfig: Remove MAX77802 RTC Kconfig symbol > > arch/arm/configs/exynos_defconfig | 1 - > arch/arm/configs/multi_v7_defconfig | 1 - > drivers/rtc/Kconfig | 10 - > drivers/rtc/Makefile | 1 - > drivers/rtc/rtc-max77686.c | 325 ++++++++++++++++++----- > drivers/rtc/rtc-max77802.c | 502 ------------------------------------ > 6 files changed, 264 insertions(+), 576 deletions(-) > delete mode 100644 drivers/rtc/rtc-max77802.c > > -- > 2.5.0 > > -- > To unsubscribe from this list: send the line "unsubscribe linux-samsung-soc" in > the body of a message to majordomo@vger.kernel.org > More majordomo info at http://vger.kernel.org/majordomo-info.html