mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
To: Peter Hurley <peter@hurleysoftware.com>
Cc: Jiri Slaby <jslaby@suse.cz>,
	linux-kernel@vger.kernel.org, linux-serial@vger.kernel.org
Subject: Re: [PATCH v2 9/9] tty: Use test_bit() with tty->flags
Date: Thu, 28 Jan 2016 14:13:29 -0800	[thread overview]
Message-ID: <20160128221329.GA6427@kroah.com> (raw)
In-Reply-To: <1452486976-7594-10-git-send-email-peter@hurleysoftware.com>

On Sun, Jan 10, 2016 at 08:36:16PM -0800, Peter Hurley wrote:
> tty->flags are handled with atomic bit ops; use test_bit() treewide.
> 
> Signed-off-by: Peter Hurley <peter@hurleysoftware.com>
> ---
>  arch/ia64/hp/sim/simserial.c       | 2 +-
>  drivers/char/pcmcia/synclink_cs.c  | 2 +-
>  drivers/isdn/i4l/isdn_tty.c        | 6 +++---
>  drivers/s390/char/tty3270.c        | 4 ++--
>  drivers/staging/dgap/dgap.c        | 2 +-
>  drivers/staging/dgnc/dgnc_tty.c    | 2 +-
>  drivers/tty/amiserial.c            | 6 +++---
>  drivers/tty/serial/68328serial.c   | 2 +-
>  drivers/tty/serial/crisv10.c       | 4 ++--
>  drivers/tty/serial/serial_core.c   | 6 +++---
>  drivers/tty/synclink.c             | 4 ++--
>  drivers/tty/synclink_gt.c          | 4 ++--
>  drivers/tty/synclinkmp.c           | 4 ++--
>  drivers/tty/tty_port.c             | 2 +-
>  net/irda/ircomm/ircomm_tty_ioctl.c | 6 +++---
>  15 files changed, 28 insertions(+), 28 deletions(-)
> 
> diff --git a/arch/ia64/hp/sim/simserial.c b/arch/ia64/hp/sim/simserial.c
> index e70cade..2ab9ba6 100644
> --- a/arch/ia64/hp/sim/simserial.c
> +++ b/arch/ia64/hp/sim/simserial.c
> @@ -300,7 +300,7 @@ static int rs_ioctl(struct tty_struct *tty, unsigned int cmd, unsigned long arg)
>  	if ((cmd != TIOCGSERIAL) && (cmd != TIOCSSERIAL) &&
>  	    (cmd != TIOCSERCONFIG) && (cmd != TIOCSERGSTRUCT) &&
>  	    (cmd != TIOCMIWAIT)) {
> -		if (tty->flags & (1 << TTY_IO_ERROR))
> +		if (test_bit(TTY_IO_ERROR, &tty->flags))

I thought you were going to wrap these up in a tty_*() macro instead of
open-coding it everywhere?  That way you can change how those
bits/features are represented in the future, which is what I thought you
wanted to do?

Even if you don't want to do that, something like:

static inline int tty_is_io_error(struct tty_struct *tty)
{
	return test_bit(TTY_IO_ERROR, &tty->flags);
}

and then this patch would just be:
		if (tty_is_io_error(tty))

Or something like that, I'm not sold on the name, I'm sure you can pick
a better one :)

Sound reasonable?

I'll not apply this patch in the series for now.

thanks,

greg k-h

  reply	other threads:[~2016-01-28 22:13 UTC|newest]

Thread overview: 15+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-01-11  4:36 [PATCH v2 0/9] Misc tty fixes & cleanups Peter Hurley
2016-01-11  4:36 ` [PATCH v2 1/9] tty: rocket: Remove private close_wait Peter Hurley
2016-01-11  4:36 ` [PATCH v2 2/9] n_tty: Ignore all read data when closing Peter Hurley
2016-01-11  4:36 ` [PATCH v2 3/9] ia64: Pin controlling tty for unaligned fault message Peter Hurley
2016-01-11  4:36 ` [PATCH v2 4/9] staging: dgap: Remove redundant write_wait wakeups Peter Hurley
2016-01-11  4:36 ` [PATCH v2 5/9] tty: Fix GPF in flush_to_ldisc(), part 2 Peter Hurley
2016-01-11  4:36 ` [PATCH v2 6/9] tty: Unify receive_buf() code paths Peter Hurley
2016-01-11  4:36 ` [PATCH v2 7/9] tty: Allow unreadable mess to be > 80 chars Peter Hurley
2016-01-11  4:36 ` [PATCH v2 8/9] tty: Use termios c_*flag macros Peter Hurley
2016-01-19 14:38   ` Johan Hovold
2016-01-11  4:36 ` [PATCH v2 9/9] tty: Use test_bit() with tty->flags Peter Hurley
2016-01-28 22:13   ` Greg Kroah-Hartman [this message]
2016-01-28 22:19     ` Peter Hurley
2016-01-28 22:22       ` Greg Kroah-Hartman
2016-04-10  0:06         ` [PATCH] tty: Replace TTY_IO_ERROR bit tests with tty_io_error() Peter Hurley

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20160128221329.GA6427@kroah.com \
    --to=gregkh@linuxfoundation.org \
    --cc=jslaby@suse.cz \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-serial@vger.kernel.org \
    --cc=peter@hurleysoftware.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome