mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Darren Hart <dvhart@infradead.org>
To: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Cc: "Pali Rohár" <pali.rohar@gmail.com>,
	"Michał Kępień" <kernel@kempniu.pl>,
	"Matthew Garrett" <mjg59@srcf.ucam.org>,
	"Richard Purdie" <rpurdie@rpsys.net>,
	"Jacek Anaszewski" <j.anaszewski@samsung.com>,
	platform-driver-x86@vger.kernel.org, linux-leds@vger.kernel.org,
	linux-kernel@vger.kernel.org
Subject: Re: [PATCH v2 00/16] Common Dell SMBIOS API
Date: Mon, 8 Feb 2016 12:46:46 -0800	[thread overview]
Message-ID: <20160208204646.GQ1779@malice.jf.intel.com> (raw)
In-Reply-To: <20160208192920.GA10110@kroah.com>

On Mon, Feb 08, 2016 at 11:29:20AM -0800, Greg Kroah-Hartman wrote:
> On Mon, Feb 08, 2016 at 11:20:14AM -0800, Darren Hart wrote:
> > On Fri, Jan 22, 2016 at 03:48:51PM +0100, Pali Rohár wrote:
> > > On Friday 22 January 2016 15:27:12 Michał Kępień wrote:
> > > > Note:
> > > > 
> > > >     In this series (both v1 and v2) I tried to stick to the overall
> > > >     concept used in dell-laptop, but in the v1 thread me and Pali also
> > > >     briefly discussed his alternative ideas [1][2] as to what this API
> > > >     could look like, so feel free to suggest a different approach.
> > > > 
> > > > [1] http://www.spinics.net/lists/platform-driver-x86/msg08260.html
> > > > [2] http://www.spinics.net/lists/platform-driver-x86/msg08268.html
> > > 
> > > I would like to hear opinion about dell-smbios API also from other
> > > people. Darren, can you look and comment it?
> > 
> > This is an excellently prepared series, nice work Michał.
> > 
> > Most of my concerns were addressed by later patches in the series. I have pushed
> > a version of this 1/7 fixed per lkp (linux/io.h) and 7/16 with a corrected body
> > as I sent in reply to that patch. This is on my tree as the dell-smbios branch.
> > 
> > My only major concern is module load order dependencies. Inter-module
> > dependencies are frowned upon with good reason, the kernel load ordering is
> > non-deterministic and it's possible, for example, for dell-laptop to fail to
> > find the symbols exported by dell-smbios under certain conditions.
> > 
> > I have worked around this in the past with things like the following:
> > 
> > #ifdef MODULE
> > #ifdef CONFIG_FOO_MODULE
> > 	if (request_module("foo"))
> > 		return -ENODEV;
> > #endif
> > #endif
> > 
> > Something like the above may be necessary for dell-smbios in dell-laptop,
> > dell-wmi, and dell-leds now that they depend on the dell-smbios exported
> > functions.
> > 
> > Cc Greg in case there is a better way to handle this that I'm not aware of.
> 
> No need to request_module anything, the symbol resolution should pull
> the dependant module in automagically when you do a 'modprobe',
> otherwise the symbols would never be found.

OK, Thank you Greg. Based on this, I have no concerns that haven't been addressed in the
pdx86/dell-smbios branch.

Michał, did you have any changes you wanted to make?

Pali, are you happy enough with this to add your reviewed-by?

I'm satisfied with the series and can push to next tomorrow if we're all in
agreement.

-- 
Darren Hart
Intel Open Source Technology Center

  reply	other threads:[~2016-02-08 20:46 UTC|newest]

Thread overview: 33+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-01-22 14:27 Michał Kępień
2016-01-22 14:27 ` [PATCH v2 01/16] dell-laptop: extract SMBIOS-related code to a separate module Michał Kępień
2016-01-24  2:16   ` kbuild test robot
2016-01-26 13:33     ` Michał Kępień
2016-01-22 14:27 ` [PATCH v2 02/16] dell-smbios: rename get_buffer() to dell_smbios_get_buffer() Michał Kępień
2016-01-22 14:27 ` [PATCH v2 03/16] dell-smbios: rename clear_buffer() to dell_smbios_clear_buffer() Michał Kępień
2016-01-22 14:27 ` [PATCH v2 04/16] dell-smbios: rename release_buffer() to dell_smbios_release_buffer() Michał Kępień
2016-01-22 14:27 ` [PATCH v2 05/16] dell-smbios: rename dell_send_request() to dell_smbios_send_request() Michał Kępień
2016-01-22 14:27 ` [PATCH v2 06/16] dell-smbios: don't pass an SMBIOS buffer " Michał Kępień
2016-01-22 14:27 ` [PATCH v2 07/16] dell-smbios: don't return an SMBIOS buffer from dell_smbios_send_request() Michał Kępień
2016-02-08 18:44   ` Darren Hart
2016-02-09 13:27     ` Michał Kępień
2016-02-09 16:50       ` Darren Hart
2016-02-09 17:34         ` Michał Kępień
2016-01-22 14:27 ` [PATCH v2 08/16] dell-smbios: return the SMBIOS buffer from dell_smbios_get_buffer() Michał Kępień
2016-01-22 14:27 ` [PATCH v2 09/16] dell-smbios: make the SMBIOS buffer static Michał Kępień
2016-01-22 14:27 ` [PATCH v2 10/16] dell-smbios: implement new function for finding DMI table 0xDA tokens Michał Kępień
2016-01-22 14:27 ` [PATCH v2 11/16] dell-laptop: use dell_smbios_find_token() instead of find_token_id() Michał Kępień
2016-01-22 14:27 ` [PATCH v2 12/16] dell-laptop: use dell_smbios_find_token() instead of find_token_location() Michał Kępień
2016-01-22 14:27 ` [PATCH v2 13/16] dell-smbios: remove find_token_{id,location}() Michał Kępień
2016-01-22 14:27 ` [PATCH v2 14/16] dell-smbios: make da_tokens static Michał Kępień
2016-01-22 14:27 ` [PATCH v2 15/16] dell-led: use dell_smbios_find_token() for finding mic DMI tokens Michał Kępień
2016-01-22 14:27 ` [PATCH v2 16/16] dell-led: use dell_smbios_send_request() for performing SMBIOS calls Michał Kępień
2016-01-22 14:48 ` [PATCH v2 00/16] Common Dell SMBIOS API Pali Rohár
2016-02-07 20:34   ` Darren Hart
2016-02-08 19:20   ` Darren Hart
2016-02-08 19:29     ` Greg Kroah-Hartman
2016-02-08 20:46       ` Darren Hart [this message]
2016-02-08 21:04         ` Pali Rohár
2016-02-08 21:31           ` Darren Hart
2016-02-09 14:15         ` Michał Kępień
2016-02-08 19:30     ` Lukas Wunner
2016-02-08 20:43       ` Darren Hart

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20160208204646.GQ1779@malice.jf.intel.com \
    --to=dvhart@infradead.org \
    --cc=gregkh@linuxfoundation.org \
    --cc=j.anaszewski@samsung.com \
    --cc=kernel@kempniu.pl \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-leds@vger.kernel.org \
    --cc=mjg59@srcf.ucam.org \
    --cc=pali.rohar@gmail.com \
    --cc=platform-driver-x86@vger.kernel.org \
    --cc=rpurdie@rpsys.net \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome