From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1753209AbcBJSKD (ORCPT ); Wed, 10 Feb 2016 13:10:03 -0500 Received: from mga04.intel.com ([192.55.52.120]:16320 "EHLO mga04.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1752234AbcBJSKA (ORCPT ); Wed, 10 Feb 2016 13:10:00 -0500 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.22,426,1449561600"; d="scan'208";a="881413279" Subject: [PATCH 0/3] [RFC] get_user_pages_remote(), now with creative macros To: linux-kernel@vger.kernel.org Cc: linux-mm@kvack.org, x86@kernel.org, torvalds@linux-foundation.org, Dave Hansen , srikar@linux.vnet.ibm.com, vbabka@suse.cz, akpm@linux-foundation.org, kirill.shutemov@linux.intel.com, aarcange@redhat.com, n-horiguchi@ah.jp.nec.com, jack@suse.cz From: Dave Hansen Date: Wed, 10 Feb 2016 10:10:00 -0800 Message-Id: <20160210181000.886CDF18@viggo.jf.intel.com> Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org This is responding to some feedback from Ingo on the "get_user_pages_foreign()" patch: http://lkml.kernel.org/r/20160209124649.GA20153@gmail.com This new series breaks apart some of the changes in that original patch and adds some backward-compatibility to allow old-style get_user_pages() arguments to not break the build. The macros to do this are "fun". See patch #2. We also change the name to get_user_pages_remote(). This is a preparatory patch for the Memory Protection Keys work, but I am sending this separately for review to spare you from the ~30 other patches in the series that have not changed. cc: srikar dronamraju cc: vlastimil babka cc: andrew morton cc: kirill a. shutemov cc: andrea arcangeli cc: naoya horiguchi cc: jack@suse.cz