mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Kenneth Westfield <kwestfie@codeaurora.org>
To: Srinivas Kandagatla <srinivas.kandagatla@linaro.org>
Cc: Patrick Lai <plai@codeaurora.org>,
	alsa-devel@alsa-project.org, Mark Brown <broonie@kernel.org>,
	Banajit Goswami <bgoswami@codeaurora.org>,
	Liam Girdwood <lgirdwood@gmail.com>,
	Jaroslav Kysela <perex@perex.cz>, Takashi Iwai <tiwai@suse.com>,
	linux-kernel@vger.kernel.org, linux-arm-msm@vger.kernel.org,
	kwestfie@codeaurora.org
Subject: Re: [PATCH v1 13/14] ASoC: qcom: add mic support
Date: Wed, 10 Feb 2016 12:10:21 -0800	[thread overview]
Message-ID: <20160210201021.GB29575@kwestfie-linux.qualcomm.com> (raw)
In-Reply-To: <1455099603-906-1-git-send-email-srinivas.kandagatla@linaro.org>

On Wed, Feb 10, 2016 at 02:20:03AM -0800, Srinivas Kandagatla wrote:
> diff --git a/sound/soc/qcom/lpass-platform.c
> b/sound/soc/qcom/lpass-platform.c
> index 26a046a..574aa33 100644
> --- a/sound/soc/qcom/lpass-platform.c
> +++ b/sound/soc/qcom/lpass-platform.c

...

> @@ -92,7 +93,13 @@ static int lpass_platform_pcmops_hw_params(struct
> snd_pcm_substream *substream,
>  	unsigned int regval;
>  	int dir = substream->stream;
>  	int bitwidth;
> -	int ret, rdma_port = pcm_data->i2s_port + v->dmactl_audif_start;
> +	int ch, ret, dma_port = pcm_data->i2s_port +
> v->dmactl_audif_start;

IMO, changing rdma_port to dma_port should be in patch 3 (ASoC: qcom:
rename rdmactl_audif_start to dmactrl_audif_start).  However, as I
stated in my comments to your RFC submission, this is a nit.

...

> @@ -460,55 +483,106 @@ static int lpass_platform_pcm_new(struct
> snd_soc_pcm_runtime *soc_runtime)
>  	if (!data)
>  		return -ENOMEM;
>  
> -	if (v->alloc_dma_channel)
> -		data->rdma_ch = v->alloc_dma_channel(drvdata,
> -
> SNDRV_PCM_STREAM_PLAYBACK);
> +	data->i2s_port = cpu_dai->driver->id;
> +	snd_soc_pcm_set_drvdata(soc_runtime, data);
>  
> -	if (IS_ERR_VALUE(data->rdma_ch))
> -		return data->rdma_ch;
> +	psubstream = pcm->streams[SNDRV_PCM_STREAM_PLAYBACK].substream;
> +	if (psubstream) {
> +		if (v->alloc_dma_channel)
> +			data->rdma_ch = v->alloc_dma_channel(drvdata,
> +
> SNDRV_PCM_STREAM_PLAYBACK);
>  
> -	drvdata->substream[data->rdma_ch] = substream;
> -	data->i2s_port = cpu_dai->driver->id;
> +		if (IS_ERR_VALUE(data->rdma_ch))
> +			return data->rdma_ch;
>  
> -	snd_soc_pcm_set_drvdata(soc_runtime, data);
> +		drvdata->substream[data->rdma_ch] = psubstream;
>  
> -	ret = snd_dma_alloc_pages(SNDRV_DMA_TYPE_DEV,
> -				soc_runtime->platform->dev,
> -				size, &substream->dma_buffer);
> -	if (ret)
> -		return ret;
> +		ret = snd_dma_alloc_pages(SNDRV_DMA_TYPE_DEV,
> pcm->card->dev,
> +					size, &psubstream->dma_buffer);

In patch 1 of this series (ASoC: qcom: use snd_dma_alloc/free* apis), you
correctly used the platform device for memory allocation.  However, that is
then replaced by the soundcard device here ...

> +	csubstream = pcm->streams[SNDRV_PCM_STREAM_CAPTURE].substream;
> +	if (csubstream) {
> +		if (v->alloc_dma_channel)
> +			data->wrdma_ch = v->alloc_dma_channel(drvdata,
> +						SNDRV_PCM_STREAM_CAPTURE);
> +
> +		if (IS_ERR_VALUE(data->wrdma_ch))
> +			goto capture_alloc_err;
> +
> +		drvdata->substream[data->wrdma_ch] = csubstream;
> +
> +		ret = snd_dma_alloc_pages(SNDRV_DMA_TYPE_DEV,
> pcm->card->dev,
> +					size, &csubstream->dma_buffer);
> +		if (ret)
> +			goto capture_alloc_err;

... and here as well.

-- 
Kenneth Westfield
Qualcomm Innovation Center, Inc.
The Qualcomm Innovation Center, Inc. is a member of the Code Aurora Forum, 
a Linux Foundation Collaborative Project

  reply	other threads:[~2016-02-10 20:10 UTC|newest]

Thread overview: 21+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-02-10 10:16 [PATCH v1 00/14] ASoC: qcom: Add capture support Srinivas Kandagatla
2016-02-10 10:18 ` [PATCH v1 01/14] ASoC: qcom: use snd_dma_alloc/free* apis Srinivas Kandagatla
2016-02-10 10:18 ` [PATCH v1 02/14] ASoC: qcom: add wrdma register details to lpass_variant Srinivas Kandagatla
2016-02-10 10:18 ` [PATCH v1 03/14] ASoC: qcom: rename rdmactl_audif_start to dmactrl_audif_start Srinivas Kandagatla
2016-02-10 10:18 ` [PATCH v1 04/14] ASoC: qcom: pass direction to dma allocation Srinivas Kandagatla
2016-02-10 10:18 ` [PATCH v1 05/14] ASoC: qcom: ipq806x: add error in " Srinivas Kandagatla
2016-02-10 10:19 ` [PATCH v1 06/14] ASoC: qcom: rename rdma_ch_bit_map to dma_ch_bit_map Srinivas Kandagatla
2016-02-10 10:19 ` [PATCH v1 07/14] ASoC: qcom: ipq806x: add wrdma related register offsets Srinivas Kandagatla
2016-02-10 10:19 ` [PATCH v1 08/14] ASoC: qcom: apq8016: add wrdma support Srinivas Kandagatla
2016-02-10 10:19 ` [PATCH v1 09/14] ASoC: qcom: add mic related i2s control register defines Srinivas Kandagatla
2016-02-10 10:19 ` [PATCH v1 10/14] ASoC: qcom: add wrdma register definitions Srinivas Kandagatla
2016-02-10 10:19 ` [PATCH v1 11/14] ASoC: qcom: add generic bit masks for RDMA and WRDMA Srinivas Kandagatla
2016-02-10 10:19 ` [PATCH v1 12/14] ASoC: qcom: apq8016: set the correct max register for regmap Srinivas Kandagatla
2016-02-10 10:20 ` [PATCH v1 13/14] ASoC: qcom: add mic support Srinivas Kandagatla
2016-02-10 20:10   ` Kenneth Westfield [this message]
2016-02-11 11:34     ` Srinivas Kandagatla
2016-02-10 10:20 ` [PATCH v1 14/14] ASoC: qcom: apq8016-sbc: " Srinivas Kandagatla
2016-02-10 10:22 ` [PATCH v1 00/14] ASoC: qcom: Add capture support Mark Brown
2016-02-10 10:39   ` Srinivas Kandagatla
2016-02-10 11:51     ` Mark Brown
2016-02-10 20:10 ` Kenneth Westfield

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20160210201021.GB29575@kwestfie-linux.qualcomm.com \
    --to=kwestfie@codeaurora.org \
    --cc=alsa-devel@alsa-project.org \
    --cc=bgoswami@codeaurora.org \
    --cc=broonie@kernel.org \
    --cc=lgirdwood@gmail.com \
    --cc=linux-arm-msm@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=perex@perex.cz \
    --cc=plai@codeaurora.org \
    --cc=srinivas.kandagatla@linaro.org \
    --cc=tiwai@suse.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®