mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Greg KH <gregkh@linuxfoundation.org>
To: "Gavin O'Leary" <gavinoleary3@gmail.com>
Cc: sparmaintainer@unisys.com, devel@driverdev.osuosl.org,
	linux-kernel@vger.kernel.org
Subject: Re: [PATCH] staging: unisys: visornic: Made comments look nicer
Date: Wed, 16 Mar 2016 20:27:51 -0700	[thread overview]
Message-ID: <20160317032751.GA31052@kroah.com> (raw)
In-Reply-To: <1458183645-6943-1-git-send-email-gavinoleary3@gmail.com>

On Wed, Mar 16, 2016 at 08:00:45PM -0700, Gavin O'Leary wrote:
> Made comments not break coding style guidlines and easier to read.
> 
> Signed-off-by: Gavin O'Leary <gavinoleary3@gmail.com>
> ---
>  drivers/staging/unisys/visornic/visornic_main.c | 29 +++++++++++++++----------
>  1 file changed, 17 insertions(+), 12 deletions(-)
> 
> diff --git a/drivers/staging/unisys/visornic/visornic_main.c b/drivers/staging/unisys/visornic/visornic_main.c
> index 0519470..50ad44e 100644
> --- a/drivers/staging/unisys/visornic/visornic_main.c
> +++ b/drivers/staging/unisys/visornic/visornic_main.c
> @@ -1215,11 +1215,13 @@ visornic_rx(struct uiscmdrsp *cmdrsp)
>  					"repost_return failed");
>  			return rx_count;
>  		}
> -		/* length rcvd is greater than firstfrag in this skb rcv buf  */
> -		skb->tail += RCVPOST_BUF_SIZE;	/* amount in skb->data */
> -		skb->data_len = skb->len - RCVPOST_BUF_SIZE;	/* amount that
> -								   will be in
> -								   frag_list */
> +		/* length rcvd is greater than firstfrag in this skb rcv buf*/
> +

Why the blank line?

> +		/*amount in skb->data */

/* amount...

> +		skb->tail += RCVPOST_BUF_SIZE;
> +
> +		/* amount that will be in frag_list */
> +		skb->data_len = skb->len - RCVPOST_BUF_SIZE;
>  	} else {
>  		/* data fits in this skb - no chaining - do
>  		 * PRECAUTIONARY check
> @@ -1313,14 +1315,18 @@ visornic_rx(struct uiscmdrsp *cmdrsp)
>  						break;
>  					}
>  				}
> +
> +				/* accept packet, dest matches a multicast
> +				 * address
> +				 */

Not correct format :(

>  				if (found_mc)
> -					break;	/* accept packet, dest
> -						   matches a multicast
> -						   address */
> +					break;
>  			}
> +
> +		/* accept packet, dest matches a multicast address */

Why say it twice?

>  		} else if (skb->pkt_type == PACKET_HOST) {
> -			break;	/* accept packet, h_dest must match vnic
> -				   mac address */

You dropped this comment?

Please relax, take a day off, and don't rush this, there's nothing I can
do with any patches at the moment with the merge window being opened
until 2 weeks from now anyway.

greg k-h

  reply	other threads:[~2016-03-17  3:27 UTC|newest]

Thread overview: 3+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-03-17  3:00 Gavin O'Leary
2016-03-17  3:27 ` Greg KH [this message]
  -- strict thread matches above, loose matches on Subject: below --
2016-03-17  2:55 Gavin O'Leary

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20160317032751.GA31052@kroah.com \
    --to=gregkh@linuxfoundation.org \
    --cc=devel@driverdev.osuosl.org \
    --cc=gavinoleary3@gmail.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=sparmaintainer@unisys.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®