From: Tejun Heo <tj@kernel.org>
To: Ming Lin <mlin@kernel.org>
Cc: linux-kernel@vger.kernel.org, linux-scsi@vger.kernel.org,
Christoph Hellwig <hch@lst.de>
Subject: Re: [PATCH v3 4/5] scsi: rename SCSI_MAX_{SG, SG_CHAIN}_SEGMENTS
Date: Tue, 5 Apr 2016 10:55:55 -0400 [thread overview]
Message-ID: <20160405145555.GE7822@mtj.duckdns.org> (raw)
In-Reply-To: <1459806491-16428-5-git-send-email-mlin@kernel.org>
On Mon, Apr 04, 2016 at 02:48:10PM -0700, Ming Lin wrote:
> From: Ming Lin <ming.l@ssi.samsung.com>
>
> Rename SCSI_MAX_SG_SEGMENTS to SG_CHUNK_SIZE, which means the amount
> we fit into a single scatterlist chunk.
>
> Rename SCSI_MAX_SG_CHAIN_SEGMENTS to SG_MAX_SEGMENTS.
>
> Will move these 2 generic definitions to scatterlist.h later.
>
> Reviewed-by: Christoph Hellwig <hch@lst.de>
> Acked-by: Bart Van Assche <bart.vanassche@sandisk.com> (for ib_srp changes)
> Signed-off-by: Ming Lin <ming.l@ssi.samsung.com>
For libata,
Acked-by: Tejun Heo <tj@kernel.org>
Thanks.
--
tejun
next prev parent reply other threads:[~2016-04-05 14:55 UTC|newest]
Thread overview: 18+ messages / expand[flat|nested] mbox.gz Atom feed top
2016-04-04 21:48 [PATCH v3 0/5] mempool based chained scatterlist alloc/free api Ming Lin
2016-04-04 21:48 ` [PATCH v3 1/5] scsi: replace "scsi_data_buffer" with "sg_table" in SG functions Ming Lin
2016-04-12 10:36 ` Sagi Grimberg
2016-04-04 21:48 ` [PATCH v3 2/5] scsi: replace "mq" with "first_chunk" " Ming Lin
2016-04-12 10:36 ` Sagi Grimberg
2016-04-04 21:48 ` [PATCH v3 3/5] scsi: rename SG related struct and functions Ming Lin
2016-04-12 10:40 ` Sagi Grimberg
2016-04-04 21:48 ` [PATCH v3 4/5] scsi: rename SCSI_MAX_{SG, SG_CHAIN}_SEGMENTS Ming Lin
2016-04-05 14:55 ` Tejun Heo [this message]
2016-04-11 5:20 ` Ming Lin
2016-04-11 21:34 ` Martin K. Petersen
2016-04-11 22:04 ` Ming Lin
2016-04-12 2:43 ` Bart Van Assche
2016-04-12 10:42 ` Sagi Grimberg
2016-04-12 10:34 ` Sagi Grimberg
2016-04-12 22:00 ` Martin K. Petersen
2016-04-04 21:48 ` [PATCH v3 5/5] lib: scatterlist: move SG pool code from SCSI driver to lib/sg_pool.c Ming Lin
2016-04-12 10:44 ` Sagi Grimberg
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20160405145555.GE7822@mtj.duckdns.org \
--to=tj@kernel.org \
--cc=hch@lst.de \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-scsi@vger.kernel.org \
--cc=mlin@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®