From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1756404AbcDGM4s (ORCPT ); Thu, 7 Apr 2016 08:56:48 -0400 Received: from mga01.intel.com ([192.55.52.88]:43337 "EHLO mga01.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1756372AbcDGM4o (ORCPT ); Thu, 7 Apr 2016 08:56:44 -0400 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.24,449,1455004800"; d="scan'208";a="780036224" Date: Thu, 7 Apr 2016 15:56:34 +0300 From: Mika Westerberg To: Irina Tirdea Cc: "Rafael J. Wysocki" , Len Brown , Linus Walleij , linux-gpio@vger.kernel.org, linux-acpi@vger.kernel.org, Rob Herring , Heikki Krogerus , Andy Shevchenko , Octavian Purdila , Cristina Ciocan , devicetree@vger.kernel.org, linux-kernel@vger.kernel.org Subject: Re: [RFC PATCH v2 0/3] Add ACPI support for pinctrl configuration Message-ID: <20160407125634.GO1727@lahna.fi.intel.com> References: <1459870406-15219-1-git-send-email-irina.tirdea@intel.com> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <1459870406-15219-1-git-send-email-irina.tirdea@intel.com> Organization: Intel Finland Oy - BIC 0357606-4 - Westendinkatu 7, 02160 Espoo User-Agent: Mutt/1.5.24 (2015-08-30) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Tue, Apr 05, 2016 at 06:33:23PM +0300, Irina Tirdea wrote: > This is a proposal for adding ACPI support for pin controller > configuration. > > It has been developed to enable the MinnowBoard and IoT community > by providing an easy way to specify pin multiplexing and > pin configuration. > > This proposal is based on using _DSD properties to specify device > states and configuration nodes and it follows closely the device > tree model. Device states are defined using the Device Properties > format and the configuration nodes are defined using the > Hierarchical Properties Extension format. The generic properties > for the configuration nodes are the same as the ones for device > tree, while pincontroller drivers can also define custom ones. > > Changes from v1: > - address code review comments regarding coding style, documentation > and fixes > - rewrote patch 3 ("pinctrl: Parse GpioInt/GpioIo resources") to > avoid using triple pointers > - define pinconf_generic_dt_node_to_map since it is used by pinctrl > sirf driver > - add dependency on PINCONF_GENERIC to the entire ACPI parsing code > - dropped first patch from the series since it got merged > ("pinctrl: Rename pinctrl_utils_dt_free_map to pinctrl_utils_free_map") > > Irina Tirdea (3): > pinctrl: pinconf-generic: Add ACPI support > pinctrl: Add ACPI support > pinctrl: Parse GpioInt/GpioIo resources The series looks good to me now, Reviewed-by: Mika Westerberg Of course this all depends on the decision whether this is the preferred way of controlling and muxing pins in ACPI.