mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Ingo Molnar <mingo@kernel.org>
To: Alexander Shishkin <alexander.shishkin@linux.intel.com>
Cc: Peter Zijlstra <peterz@infradead.org>,
	Gleb Natapov <gleb@kernel.org>,
	Paolo Bonzini <pbonzini@redhat.com>,
	x86@kernel.org, kvm@vger.kernel.org,
	Ingo Molnar <mingo@redhat.com>,
	linux-kernel@vger.kernel.org, tglx@linutronix.de, hpa@zytor.com,
	Arnaldo Carvalho de Melo <acme@infradead.org>,
	Borislav Petkov <bp@alien8.de>
Subject: Re: [PATCH] perf/x86/intel/pt: Don't die on VMXON
Date: Wed, 13 Apr 2016 12:53:31 +0200	[thread overview]
Message-ID: <20160413105331.GA30907@gmail.com> (raw)
In-Reply-To: <87r3e9x0hi.fsf@ashishki-desk.ger.corp.intel.com>


* Alexander Shishkin <alexander.shishkin@linux.intel.com> wrote:

> Ingo Molnar <mingo@kernel.org> writes:
> 
> >> @@ -3144,6 +3146,8 @@ static void vmclear_local_loaded_vmcss(void)
> >>  static void kvm_cpu_vmxoff(void)
> >>  {
> >>  	asm volatile (__ex(ASM_VMX_VMXOFF) : : : "cc");
> >> +
> >> +	intel_pt_vmx(0);
> >>  }
> >
> > Yeah so the name intel_pt_vmx() is pretty information-free because it has no verb, 
> > only nouns - please name new functions descriptively to after what they do!
> 
> I do agree that it can use a better name (and this is a second attempt
> already).
> 
> > Something like intel_pt_set_vmx_state() or so?
> 
> Hmm how about intel_pt_handle_vmx()? Ideally, akin to the VMXON/VMXOFF insns, 
> this could be two functions (intel_pt_handle_vmx{on,off}()) if the global 
> namespace can take it.

Sure, intel_pt_handle_vmx(0/1) sounds good too. I wouldn't split it into two 
functions ...

Thanks,

	Ingo

  reply	other threads:[~2016-04-13 10:53 UTC|newest]

Thread overview: 12+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-04-01 16:24 Alexander Shishkin
2016-04-06  8:52 ` Peter Zijlstra
2016-04-06 11:10   ` Alexander Shishkin
2016-04-06 11:52     ` Peter Zijlstra
2016-04-06 11:55       ` Borislav Petkov
2016-04-06 12:07         ` Alexander Shishkin
2016-04-06 14:06       ` Alexander Shishkin
2016-04-13  9:49         ` Ingo Molnar
2016-04-13 10:32           ` Alexander Shishkin
2016-04-13 10:53             ` Ingo Molnar [this message]
2016-04-13 13:48               ` Alexander Shishkin
2016-04-28 10:25                 ` [tip:perf/core] " tip-bot for Alexander Shishkin

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20160413105331.GA30907@gmail.com \
    --to=mingo@kernel.org \
    --cc=acme@infradead.org \
    --cc=alexander.shishkin@linux.intel.com \
    --cc=bp@alien8.de \
    --cc=gleb@kernel.org \
    --cc=hpa@zytor.com \
    --cc=kvm@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@redhat.com \
    --cc=pbonzini@redhat.com \
    --cc=peterz@infradead.org \
    --cc=tglx@linutronix.de \
    --cc=x86@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome