From: Borislav Petkov <bp@alien8.de>
To: Ingo Molnar <mingo@kernel.org>
Cc: peterz@infradead.org, dsafonov@virtuozzo.com, luto@kernel.org,
hpa@zytor.com, dvlasenk@redhat.com, luto@amacapital.net,
torvalds@linux-foundation.org, brgerst@gmail.com,
linux-kernel@vger.kernel.org, tglx@linutronix.de,
linux-tip-commits@vger.kernel.org
Subject: Re: [tip:x86/asm] x86/entry: Rename is_{ia32,x32}_task() to in_{ia32,x32}_syscall()
Date: Tue, 19 Apr 2016 13:35:01 +0200 [thread overview]
Message-ID: <20160419113501.GA10638@cz.tnic> (raw)
In-Reply-To: <20160419111530.GA1619@gmail.com>
On Tue, Apr 19, 2016 at 01:15:30PM +0200, Ingo Molnar wrote:
> So I'd suggest the following renames to harmonize these concepts:
>
> - CONFIG_IA32_EMULATION => CONFIG_X86_32_ABI
> this lines up nicely with: CONFIG_X86_X32_ABI
Except that the only difference now is the "X" in the strings. So one
would need more coffee when staring at those. :)
>
> - is_ia32_syscall() -> is_x86_32_syscall()
> - is_x32_syscall() -> is_x86_x32_syscall()
>
> - is_compat_syscall() remains as-is.
>
> ... thoughts?
Still, getting those names streamlined and logical is a step in the
right direction IMO.
--
Regards/Gruss,
Boris.
ECO tip #101: Trim your mails when you reply. Srsly.
next prev parent reply other threads:[~2016-04-19 11:35 UTC|newest]
Thread overview: 56+ messages / expand[flat|nested] mbox.gz Atom feed top
2016-04-11 15:22 [PATCH] x86/vdso: add mremap hook to vm_special_mapping Dmitry Safonov
2016-04-11 15:41 ` kbuild test robot
2016-04-11 15:54 ` Dmitry Safonov
2016-04-14 16:32 ` [PATCHv2] " Dmitry Safonov
2016-04-14 22:58 ` Andy Lutomirski
2016-04-15 8:46 ` Dmitry Safonov
2016-04-15 9:18 ` Ingo Molnar
2016-04-15 9:51 ` Dmitry Safonov
2016-04-15 12:08 ` Dmitry Safonov
2016-04-15 13:20 ` [PATCHv3 1/2] " Dmitry Safonov
2016-04-15 13:20 ` [PATCHv3 2/2] x86: rename is_{ia32,x32}_task to in_{ia32,x32}_syscall Dmitry Safonov
2016-04-15 16:52 ` Andy Lutomirski
2016-04-15 16:55 ` Dmitry Safonov
2016-04-15 13:53 ` [PATCHv3 1/2] x86/vdso: add mremap hook to vm_special_mapping kbuild test robot
2016-04-15 14:12 ` [PATCHv4 " Dmitry Safonov
2016-04-15 14:12 ` [PATCHv4 2/2] x86: rename is_{ia32,x32}_task to in_{ia32,x32}_syscall Dmitry Safonov
2016-04-15 16:58 ` [PATCHv4 1/2] x86/vdso: add mremap hook to vm_special_mapping Andy Lutomirski
2016-04-18 11:18 ` Dmitry Safonov
2016-04-18 15:37 ` Andy Lutomirski
2016-04-18 13:43 ` [PATCHv5 1/3] x86: rename is_{ia32,x32}_task to in_{ia32,x32}_syscall Dmitry Safonov
2016-04-18 13:43 ` [PATCHv5 2/3] x86/vdso: add mremap hook to vm_special_mapping Dmitry Safonov
2016-04-18 14:03 ` kbuild test robot
2016-04-18 14:17 ` [PATCHv6 " Dmitry Safonov
2016-04-18 14:23 ` [PATCHv7 " Dmitry Safonov
2016-04-20 16:22 ` Dmitry Safonov
2016-04-21 19:52 ` Andy Lutomirski
2016-04-22 10:45 ` Dmitry Safonov
2016-04-23 23:09 ` [PATCHv5 " kbuild test robot
2016-04-18 13:43 ` [PATCHv5 3/3] selftest/x86: add mremap vdso 32-bit test Dmitry Safonov
2016-04-21 20:01 ` Andy Lutomirski
2016-04-22 11:34 ` Dmitry Safonov
2016-04-19 9:34 ` [tip:x86/asm] x86/entry: Rename is_{ia32,x32}_task() to in_{ia32,x32}_syscall() tip-bot for Dmitry Safonov
2016-04-19 11:15 ` Ingo Molnar
2016-04-19 11:35 ` Borislav Petkov [this message]
2016-04-19 17:00 ` H. Peter Anvin
2016-04-19 16:04 ` Andy Lutomirski
2016-04-22 8:36 ` Ingo Molnar
2018-10-18 1:47 ` in_compat_syscall() returns from kernel thread for X86_32 NeilBrown
2018-10-18 2:37 ` Andy Lutomirski
2018-10-18 2:49 ` Al Viro
2018-10-18 4:36 ` NeilBrown
2018-10-18 17:26 ` Andy Lutomirski
2018-10-20 6:02 ` Andreas Dilger
2018-10-20 7:58 ` Andy Lutomirski
2018-10-24 1:47 ` NeilBrown
2018-10-24 13:15 ` Theodore Y. Ts'o
2018-10-24 14:32 ` Theodore Y. Ts'o
2019-01-11 22:21 ` Pavel Machek
2018-10-25 3:46 ` NeilBrown
2018-10-25 4:45 ` Andy Lutomirski
2016-04-25 11:37 ` [PATCHv8 1/2] x86/vdso: add mremap hook to vm_special_mapping Dmitry Safonov
2016-04-25 11:37 ` [PATCHv8 2/2] selftest/x86: add mremap vdso test Dmitry Safonov
2016-04-25 21:39 ` Andy Lutomirski
2016-04-25 21:38 ` [PATCHv8 1/2] x86/vdso: add mremap hook to vm_special_mapping Andy Lutomirski
[not found] ` <e0a10957-ddf7-1bc4-fad6-8b5836628fce@virtuozzo.com>
2016-05-05 11:52 ` Ingo Molnar
2016-05-05 11:55 ` Dmitry Safonov
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20160419113501.GA10638@cz.tnic \
--to=bp@alien8.de \
--cc=brgerst@gmail.com \
--cc=dsafonov@virtuozzo.com \
--cc=dvlasenk@redhat.com \
--cc=hpa@zytor.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-tip-commits@vger.kernel.org \
--cc=luto@amacapital.net \
--cc=luto@kernel.org \
--cc=mingo@kernel.org \
--cc=peterz@infradead.org \
--cc=tglx@linutronix.de \
--cc=torvalds@linux-foundation.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®