From: Viresh Kumar <viresh.kumar@linaro.org>
To: Andy Shevchenko <andy.shevchenko@gmail.com>
Cc: Andy Shevchenko <andriy.shevchenko@linux.intel.com>,
Viresh Kumar <vireshk@kernel.org>,
Vinod Koul <vinod.koul@intel.com>,
"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
dmaengine <dmaengine@vger.kernel.org>,
Rob Herring <robh+dt@kernel.org>, Mark Brown <broonie@kernel.org>,
Vineet Gupta <vgupta@synopsys.com>, Tejun Heo <tj@kernel.org>
Subject: Re: [PATCH v6 2/4] dmaengine: dw: revisit data_width property
Date: Wed, 27 Apr 2016 14:00:56 +0530 [thread overview]
Message-ID: <20160427083056.GJ4225@vireshk-i7> (raw)
In-Reply-To: <CAHp75Vc=EZ1gLHpackYEAQXuTs_WCqOP1bk0SBkLJHdje3zCug@mail.gmail.com>
On 27-04-16, 11:25, Andy Shevchenko wrote:
> On Wed, Apr 27, 2016 at 9:43 AM, Viresh Kumar <viresh.kumar@linaro.org> wrote:
> > On 25-04-16, 15:35, Andy Shevchenko wrote:
> >> There are several changes are done here:
> >>
> >> - Convert the property to be in bytes
> >>
> >> Besides this is common practice for such property the use of a value in bytes
> >> much more convenient than handling the encoded value.
> >>
> >> - Rename data_width to data-width in the device tree bindings
> >>
> >> - While here, replace dwc_fast_ffs() by __ffs()
> >>
> >> The change leaves the support for old format as well just in case someone will
> >> use a newer kernel with an old device tree blob.
> >>
> >> Signed-off-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
> >> ---
> >> Documentation/devicetree/bindings/dma/snps-dma.txt | 6 ++--
> >> arch/arc/boot/dts/abilis_tb10x.dtsi | 2 +-
> >> arch/arm/boot/dts/spear13xx.dtsi | 4 +--
> >> drivers/dma/dw/core.c | 42 ++++++----------------
> >> drivers/dma/dw/platform.c | 5 ++-
> >> include/linux/platform_data/dma-dw.h | 2 +-
> >> 6 files changed, 21 insertions(+), 40 deletions(-)
> >>
> >> diff --git a/Documentation/devicetree/bindings/dma/snps-dma.txt b/Documentation/devicetree/bindings/dma/snps-dma.txt
> >> index c99c1ff..544b9b9 100644
> >> --- a/Documentation/devicetree/bindings/dma/snps-dma.txt
> >> +++ b/Documentation/devicetree/bindings/dma/snps-dma.txt
> >> @@ -13,8 +13,8 @@ Required properties:
> >> - chan_priority: priority of channels. 0 (default): increase from chan 0->n, 1:
> >> increase from chan n->0
> >> - block_size: Maximum block size supported by the controller
> >> -- data_width: Maximum data width supported by hardware per AHB master
> >> - (0 - 8bits, 1 - 16bits, ..., 5 - 256bits)
> >> +- data-width: Maximum data width supported by hardware per AHB master
> >> + (in bytes, power of 2)
> >>
> >>
> >> Optional properties:
> >> @@ -38,7 +38,7 @@ Example:
> >> chan_allocation_order = <1>;
> >> chan_priority = <1>;
> >> block_size = <0xfff>;
> >> - data_width = <3 3>;
> >> + data-width = <8 8>;
> >> };
> >
> > You broke backward compatibility with earlier DTs.
>
> How?
>
> >
> > What's backward compatibility ?
> >
> > Consider that the DT from an earlier version of kernel is part of the bootrom of
> > a SoC. Now that bootrom should work just fine with any new kernel version. i.e.
> > old DT + new kernels should always work.
>
> Yes, the property name is slightly different as meaning.
>
> If we find data-width property driver will use it, otherwise it takes
> old name and converts variable to be in bytes in the driver.
Oh, I missed that you renamed the property and taking care of both the
properties now. Sorry about that. So, you didn't break them for sure :)
But, the DT documentation doesn't contain the old property now but the code
does. I think you are required to keep the bindings currently supported by the
kernel in there. You can mark them deprecated, but can't remove them.
--
viresh
next prev parent reply other threads:[~2016-04-27 8:31 UTC|newest]
Thread overview: 13+ messages / expand[flat|nested] mbox.gz Atom feed top
[not found] <Cc:Andy Shevchenko <andriy.shevchenko@linux.intel.com>
2016-04-25 12:35 ` [PATCH v6 0/4] Fixes / cleanups in dw_dmac (affects on few subsystems) Andy Shevchenko
2016-04-25 12:35 ` [PATCH v6 1/4] dmaengine: dw: platform: check nr_masters to be non-zero Andy Shevchenko
2016-04-27 6:44 ` Viresh Kumar
2016-04-25 12:35 ` [PATCH v6 2/4] dmaengine: dw: revisit data_width property Andy Shevchenko
2016-04-27 6:43 ` Viresh Kumar
2016-04-27 8:12 ` Vinod Koul
2016-04-27 8:25 ` Andy Shevchenko
2016-04-27 8:30 ` Viresh Kumar [this message]
2016-04-27 8:39 ` Andy Shevchenko
2016-04-25 12:35 ` [PATCH v6 3/4] dmaengine: dw: keep entire platform data in struct dw_dma Andy Shevchenko
2016-04-27 6:46 ` Viresh Kumar
2016-04-25 12:35 ` [PATCH v6 4/4] dmaengine: dw: pass platform data via struct dw_dma_chip Andy Shevchenko
2016-04-27 6:47 ` Viresh Kumar
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20160427083056.GJ4225@vireshk-i7 \
--to=viresh.kumar@linaro.org \
--cc=andriy.shevchenko@linux.intel.com \
--cc=andy.shevchenko@gmail.com \
--cc=broonie@kernel.org \
--cc=dmaengine@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=robh+dt@kernel.org \
--cc=tj@kernel.org \
--cc=vgupta@synopsys.com \
--cc=vinod.koul@intel.com \
--cc=vireshk@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®