mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Thierry Reding <treding@nvidia.com>
To: Laxman Dewangan <ldewangan@nvidia.com>
Cc: <lee.jones@linaro.org>, <linus.walleij@linaro.org>,
	<robh+dt@kernel.org>, <pawel.moll@arm.com>,
	<mark.rutland@arm.com>, <gnurou@gmail.com>,
	<linux-gpio@vger.kernel.org>, <devicetree@vger.kernel.org>,
	<linux-kernel@vger.kernel.org>, <swarren@nvidia.com>,
	<irina.tirdea@intel.com>
Subject: Re: [PATCH V11 4/6] pinctrl: max77620: add pincontrol driver for MAX77620/MAX20024
Date: Fri, 29 Apr 2016 15:27:27 +0200	[thread overview]
Message-ID: <20160429132725.GB17000@ulmo.ba.sec> (raw)
In-Reply-To: <57220E92.90105@nvidia.com>

[-- Attachment #1: Type: text/plain, Size: 2656 bytes --]

On Thu, Apr 28, 2016 at 06:52:26PM +0530, Laxman Dewangan wrote:
> Hi Lee,
> 
> On Thursday 28 April 2016 03:28 PM, Laxman Dewangan wrote:
> > MAXIM Semiconductor's PMIC, MAX77620/MAX20024 has 8 GPIO pins
> > which also act as the special function in alternate mode. Also
> > there is configuration like push-pull, open drain, FPS timing
> > etc for these pins.
> > 
> > Add pin control driver to configure these parameters through
> > pin control APIs.
> > 
> > Signed-off-by: Laxman Dewangan <ldewangan@nvidia.com>
> > Reviewed-by: Linus Walleij <linus.walleij@linaro.org>
> 
> It seems there is some mismatches on kernel-next and the mfd/for-next for
> one of patch for generic function name.
> 
> /**
> 2016-04-01    pinctrl: Rename pinctrl_utils_dt_free_map to
> pinctrl_utils_free_map    Irina Tirdea    1    -1/+1
> 
> d32f7fd3bbc32732b094d938b95169521503a9fb (patch)
> 
> pinctrl: Rename pinctrl_utils_dt_free_map to pinctrl_utils_free_map
> 
> Rename pinctrl_utils_dt_free_map to pinctrl_utils_free_map, since
> it does not depend on device tree despite the current name. This
> will enforce a consistent naming in pinctr-utils.c and will make
> it clear it can be called from outside device tree (e.g. from
> ACPI handling code).
> **/
> 
> But this is not there in MFD sub system.
> 
> In mfd tree
> .dt_free_map = pinctrl_utils_dt_free_map,
> 
> In kernel next
> .dt_free_map = pinctrl_utils_free_map,
> 
> 
>  I used APIs from the kernel-next.
> > +static const struct pinctrl_ops max77620_pinctrl_ops = {
> > +	.get_groups_count = max77620_pinctrl_get_groups_count,
> > +	.get_group_name = max77620_pinctrl_get_group_name,
> > +	.get_group_pins = max77620_pinctrl_get_group_pins,
> > +	.dt_node_to_map = pinconf_generic_dt_node_to_map_pin,
> > +	.dt_free_map = pinctrl_utils_free_map,
> > +};
> 
> 
> If you see any issue on this patch, please drop this patch and we will fix
> this later once the renamed change available all the places.

To avoid this, it's usually best to base your patches on a recent
linux-next, which I suppose is what you did, since you picked up the
new symbol. The reason that this isn't in the MFD tree is most likely
because it's a new symbol being introduced in the next release cycle
and it's not relevant in pinctrl.

You patch series will most likely be applied via different trees. MFD
patches will go through Lee's MFD tree and pinctrl patches through
Linus' pinctrl tree. Your patches based on linux-next should then apply
cleanly and build correctly in the respective trees and everything will
come together in linux-next again.

Thierry

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 819 bytes --]

  reply	other threads:[~2016-04-29 13:27 UTC|newest]

Thread overview: 13+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-04-28  9:58 [PATCH V11 0/6] Add support for MAXIM MAX77620/MAX20024 PMIC Laxman Dewangan
2016-04-28  9:58 ` [PATCH V11 1/6] mfd: add device-tree binding doc for PMIC max77620/max20024 Laxman Dewangan
2016-05-09 14:38   ` Lee Jones
2016-04-28  9:58 ` [PATCH V11 2/6] mfd: max77620: add core driver for MAX77620/MAX20024 Laxman Dewangan
2016-05-09 14:38   ` Lee Jones
2016-04-28  9:58 ` [PATCH V11 3/6] pinctrl: add DT binding doc for pincontrol of PMIC max77620/max20024 Laxman Dewangan
2016-04-28  9:58 ` [PATCH V11 4/6] pinctrl: max77620: add pincontrol driver for MAX77620/MAX20024 Laxman Dewangan
2016-04-28 13:22   ` Laxman Dewangan
2016-04-29 13:27     ` Thierry Reding [this message]
2016-04-28  9:58 ` [PATCH V11 5/6] gpio: add DT binding doc for gpio of PMIC max77620/max20024 Laxman Dewangan
2016-04-28  9:59 ` [PATCH V11 6/6] gpio: max77620: add gpio driver for MAX77620/MAX20024 Laxman Dewangan
2016-04-30 11:38   ` Linus Walleij
2016-05-02  6:17     ` Laxman Dewangan

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20160429132725.GB17000@ulmo.ba.sec \
    --to=treding@nvidia.com \
    --cc=devicetree@vger.kernel.org \
    --cc=gnurou@gmail.com \
    --cc=irina.tirdea@intel.com \
    --cc=ldewangan@nvidia.com \
    --cc=lee.jones@linaro.org \
    --cc=linus.walleij@linaro.org \
    --cc=linux-gpio@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mark.rutland@arm.com \
    --cc=pawel.moll@arm.com \
    --cc=robh+dt@kernel.org \
    --cc=swarren@nvidia.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®