From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1752696AbcEAXSH (ORCPT ); Sun, 1 May 2016 19:18:07 -0400 Received: from mga01.intel.com ([192.55.52.88]:17421 "EHLO mga01.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1752630AbcEAXSD (ORCPT ); Sun, 1 May 2016 19:18:03 -0400 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.24,564,1455004800"; d="scan'208";a="95347592" Date: Mon, 2 May 2016 01:17:53 +0200 From: Samuel Ortiz To: Michael Thalmeier Cc: Lauro Ramos Venancio , Aloisio Almeida Jr , linux-kernel@vger.kernel.org, linux-nfc@ml01.01.org, michael@thalmeier.at Subject: Re: [PATCH 07/11] NFC: pn533: improve cmd queue handling Message-ID: <20160501231753.GE19653@zurbaran.home> References: <1461249839-16962-1-git-send-email-michael.thalmeier@hale.at> <1461249839-16962-8-git-send-email-michael.thalmeier@hale.at> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <1461249839-16962-8-git-send-email-michael.thalmeier@hale.at> User-Agent: Mutt/1.5.24 (2015-08-30) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Hi Michael, On Thu, Apr 21, 2016 at 04:43:55PM +0200, Michael Thalmeier wrote: > Make sure cmd is set before a frame is passed to the transport layer for > sending. In addition pn533_send_async_complete checks if cmd is set before > accessing its members. > > Signed-off-by: Michael Thalmeier > --- > drivers/nfc/pn533/pn533.c | 54 +++++++++++++++++++++++++++++------------------ > 1 file changed, 34 insertions(+), 20 deletions(-) > > diff --git a/drivers/nfc/pn533/pn533.c b/drivers/nfc/pn533/pn533.c > index d9c5583..d1cc70a 100644 > --- a/drivers/nfc/pn533/pn533.c > +++ b/drivers/nfc/pn533/pn533.c > @@ -383,26 +383,36 @@ static void pn533_build_cmd_frame(struct pn533 *dev, u8 cmd_code, > static int pn533_send_async_complete(struct pn533 *dev) > { > struct pn533_cmd *cmd = dev->cmd; > - int status = cmd->status; > + int rc = 0; > > - struct sk_buff *req = cmd->req; > - struct sk_buff *resp = cmd->resp; > + if (cmd) { if (!cmd) { dev_dbg(dev->dev, "%s: cmd not set\n", __func__); return rc; } would make the rest of the code more readable. Cheers, Samuel.