From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1751530AbcEJSsM (ORCPT ); Tue, 10 May 2016 14:48:12 -0400 Received: from mail-pa0-f47.google.com ([209.85.220.47]:34775 "EHLO mail-pa0-f47.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1750951AbcEJSsK (ORCPT ); Tue, 10 May 2016 14:48:10 -0400 Date: Tue, 10 May 2016 11:48:06 -0700 From: Bjorn Andersson To: Lee Jones Cc: linux-arm-kernel@lists.infradead.org, linux-kernel@vger.kernel.org, kernel@stlinux.com, maxime.coquelin@st.com, ohad@wizery.com, linux-remoteproc@vger.kernel.org, Ludovic Barre Subject: Re: [PATCH 2/5] remoteproc: core: Add rproc OF look-up functions Message-ID: <20160510184806.GK1256@tuxbot> References: <1462454983-13168-1-git-send-email-lee.jones@linaro.org> <1462454983-13168-3-git-send-email-lee.jones@linaro.org> <20160506184842.GE1256@tuxbot> <20160510141658.GP19473@dell> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <20160510141658.GP19473@dell> User-Agent: Mutt/1.5.23 (2014-03-12) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Tue 10 May 07:16 PDT 2016, Lee Jones wrote: > On Fri, 06 May 2016, Bjorn Andersson wrote: > > > On Thu 05 May 06:29 PDT 2016, Lee Jones wrote: > > > > > - of_rproc_byindex(): look-up and obtain a reference to a rproc > > > using the DT phandle "rprocs" and a index. > > > > > > - of_rproc_byname(): lookup and obtain a reference to a rproc > > > using the DT phandle "rprocs" and "rproc-names". > > > > > > Signed-off-by: Ludovic Barre > > > Signed-off-by: Lee Jones > > > --- > > > > I like the idea of having these helpers, but we already have > > rproc_get_by_phandle() so these helpers should be built upon that rather > > than adding the additional list. > > Since this is a framework consideration, don't you think it would be > better to standardise the phandle name? This is common practice when > coding at a subsystem level. Some in use examples include; "clocks", > "power-domains", "mboxes", "dmas", "phys", "resets", "gpios", etc. > > Considering the aforementioned examples, I figured "rprocs" would be > suitable. > To summarize our chat for the record and others. I'm definitely in favour of this and think "rprocs" and "rproc-names" sounds good. My comment was only regarding the duplicated implementation. Regards, Bjorn