From: Masami Hiramatsu <mhiramat@kernel.org>
To: Arnaldo Carvalho de Melo <acme@kernel.org>
Cc: linux-kernel@vger.kernel.org, Namhyung Kim <namhyung@kernel.org>,
Peter Zijlstra <peterz@infradead.org>,
Ingo Molnar <mingo@redhat.com>,
Hemant Kumar <hemant@linux.vnet.ibm.com>,
Ananth N Mavinakayanahalli <ananth@linux.vnet.ibm.com>,
Brendan Gregg <brendan.d.gregg@gmail.com>
Subject: Re: [PATCH perf/core v7 07/21] perf symbol: Cleanup the code flow of dso__find_kallsyms
Date: Thu, 12 May 2016 10:46:35 +0900 [thread overview]
Message-ID: <20160512104635.04a7368428091a9665f2ca19@kernel.org> (raw)
In-Reply-To: <20160511155550.GD20258@kernel.org>
On Wed, 11 May 2016 12:55:50 -0300
Arnaldo Carvalho de Melo <acme@kernel.org> wrote:
> Em Wed, May 11, 2016 at 10:52:27PM +0900, Masami Hiramatsu escreveu:
> > Cleanup the code flow of dso__find_kallsyms() to remove
> > redundant checking code and add some comment for readability.
> >
> > Signed-off-by: Masami Hiramatsu <mhiramat@kernel.org>
> > ---
> > tools/perf/util/symbol.c | 60 +++++++++++++++++++++-------------------------
> > 1 file changed, 27 insertions(+), 33 deletions(-)
> >
> > diff --git a/tools/perf/util/symbol.c b/tools/perf/util/symbol.c
> > index e112bbd..b2b06b7 100644
> > --- a/tools/perf/util/symbol.c
> > +++ b/tools/perf/util/symbol.c
> > @@ -1629,6 +1629,15 @@ static int find_matching_kcore(struct map *map, char *dir, size_t dir_sz)
> > return ret;
> > }
> >
> > +static bool filename__readable(const char *file)
> > +{
> > + int fd = open(file, O_RDONLY);
> > + if (fd < 0)
> > + return false;
> > + close(fd);
> > + return true;
> > +}
>
> Do we really have to use this big hammer just for checking if a file is
> readable? What is wronte with:
>
> access(pathname, R_OK)
>
> ?
Yes, I actually had done that at prototyping. But as the manpage of access
said, access() checks accessibility by real uid/gid, but open() checks
by effective uid/gid. So, I considered this could cause unexpected
issue if we decided to use setuid(). I just wanted to check it was OK.
> I see, you're keeping the existing logic, but since you've gone to the
> trouble of introducing a seemingly generic function like
> filename__readable(), you could as well use the canonical way to check
> if a file is readable, namely access(R_OK), no?
I agreed in general :) If we don't can use access(R_OK) I'd like to use it.
>
> Adrian, is there something magical about /proc/kcore for this test to be
> done that way? If so, we better document not to waste our time next time
> we look at this...
Ah, right. At least I had to write a comment about it.
Thank you,
>
> - Arnaldo
>
> > +
> > static char *dso__find_kallsyms(struct dso *dso, struct map *map)
> > {
> > u8 host_build_id[BUILD_ID_SIZE];
> > @@ -1648,45 +1657,33 @@ static char *dso__find_kallsyms(struct dso *dso, struct map *map)
> > sizeof(host_build_id)) == 0)
> > is_host = dso__build_id_equal(dso, host_build_id);
> >
> > - build_id__sprintf(dso->build_id, sizeof(dso->build_id), sbuild_id);
> > -
> > - scnprintf(path, sizeof(path), "%s/%s/%s", buildid_dir,
> > - DSO__NAME_KCORE, sbuild_id);
> > -
> > - /* Use /proc/kallsyms if possible */
> > + /* Try a fast path for /proc/kallsyms if possible */
>
> How that improves the previous comment?
>
> > if (is_host) {
> > - DIR *d;
> > - int fd;
> > -
> > - /* If no cached kcore go with /proc/kallsyms */
> > - d = opendir(path);
> > - if (!d)
> > - goto proc_kallsyms;
> > - closedir(d);
> > -
> > /*
> > - * Do not check the build-id cache, until we know we cannot use
> > - * /proc/kcore.
> > + * Do not check the build-id cache, unless we know we cannot use
> > + * /proc/kcore or module maps don't match to /proc/kallsyms.
> > */
> > - fd = open("/proc/kcore", O_RDONLY);
> > - if (fd != -1) {
> > - close(fd);
> > - /* If module maps match go with /proc/kallsyms */
> > - if (!validate_kcore_addresses("/proc/kallsyms", map))
> > - goto proc_kallsyms;
> > - }
> > -
> > - /* Find kallsyms in build-id cache with kcore */
> > - if (!find_matching_kcore(map, path, sizeof(path)))
> > - return strdup(path);
> > -
> > - goto proc_kallsyms;
> > + if (filename__readable("/proc/kcore") &&
> > + !validate_kcore_addresses("/proc/kallsyms", map))
> > + goto proc_kallsyms;
> > }
> >
> > + build_id__sprintf(dso->build_id, sizeof(dso->build_id), sbuild_id);
> > +
> > /* Find kallsyms in build-id cache with kcore */
> > + scnprintf(path, sizeof(path), "%s/%s/%s",
> > + buildid_dir, DSO__NAME_KCORE, sbuild_id);
> > +
> > if (!find_matching_kcore(map, path, sizeof(path)))
> > return strdup(path);
> >
> > + /* Use current /proc/kallsyms if possible */
> > + if (is_host) {
> > +proc_kallsyms:
> > + return strdup("/proc/kallsyms");
> > + }
> > +
> > + /* Finally, find a cache of kallsyms */
> > scnprintf(path, sizeof(path), "%s/%s/%s",
> > buildid_dir, DSO__NAME_KALLSYMS, sbuild_id);
> >
> > @@ -1697,9 +1694,6 @@ static char *dso__find_kallsyms(struct dso *dso, struct map *map)
> > }
> >
> > return strdup(path);
> > -
> > -proc_kallsyms:
> > - return strdup("/proc/kallsyms");
> > }
> >
> > static int dso__load_kernel_sym(struct dso *dso, struct map *map,
--
Masami Hiramatsu <mhiramat@kernel.org>
next prev parent reply other threads:[~2016-05-12 1:46 UTC|newest]
Thread overview: 37+ messages / expand[flat|nested] mbox.gz Atom feed top
2016-05-11 13:51 [PATCH perf/core v7 00/21] perf-probe --cache and SDT support Masami Hiramatsu
2016-05-11 13:51 ` [PATCH perf/core v7 01/21] tools/perf: Fix lsdir to set errno correctly Masami Hiramatsu
2016-05-11 13:59 ` Arnaldo Carvalho de Melo
2016-05-12 1:46 ` Masami Hiramatsu
2016-05-12 10:25 ` [tip:perf/core] perf tools: " tip-bot for Masami Hiramatsu
2016-05-11 13:51 ` [PATCH perf/core v7 02/21] perf buildid: Fix to set correct dso name for kallsyms Masami Hiramatsu
2016-05-11 15:45 ` Arnaldo Carvalho de Melo
2016-05-12 2:02 ` Masami Hiramatsu
2016-05-12 8:57 ` Masami Hiramatsu
2016-05-11 13:51 ` [PATCH perf/core v7 03/21] perf buildid: Introduce DSO__NAME_KALLSYMS and DSO__NAME_KCORE Masami Hiramatsu
2016-05-11 15:47 ` Arnaldo Carvalho de Melo
2016-05-11 13:51 ` [PATCH perf/core v7 04/21] perf: Use SBUILD_ID_SIZE macro instead of BUILD_ID_SIZE macro Masami Hiramatsu
2016-05-11 15:47 ` Arnaldo Carvalho de Melo
2016-05-12 10:25 ` [tip:perf/core] perf tools: Use SBUILD_ID_SIZE where applicable tip-bot for Masami Hiramatsu
2016-05-11 13:52 ` [PATCH perf/core v7 05/21] perf symbol: Use lsdir for search in kcore cache directory Masami Hiramatsu
2016-05-11 15:49 ` Arnaldo Carvalho de Melo
2016-05-12 10:26 ` [tip:perf/core] perf symbols: Use lsdir() for the " tip-bot for Masami Hiramatsu
2016-05-11 13:52 ` [PATCH perf/core v7 06/21] perf-buildid-cache: Use lsdir for looking up buildid caches Masami Hiramatsu
2016-05-11 15:50 ` Arnaldo Carvalho de Melo
2016-05-12 10:26 ` [tip:perf/core] perf buildid-cache: Use lsdir() " tip-bot for Masami Hiramatsu
2016-05-11 13:52 ` [PATCH perf/core v7 07/21] perf symbol: Cleanup the code flow of dso__find_kallsyms Masami Hiramatsu
2016-05-11 15:55 ` Arnaldo Carvalho de Melo
2016-05-12 1:46 ` Masami Hiramatsu [this message]
2016-05-11 13:52 ` [PATCH perf/core v7 08/21] perf-buildid-cache: Use path/to/bin/buildid/elf instead of path/to/bin/buildid Masami Hiramatsu
2016-05-11 13:52 ` [PATCH perf/core v7 09/21] perf probe: Add --cache option to cache the probe definitions Masami Hiramatsu
2016-05-11 13:52 ` [PATCH perf/core v7 10/21] perf probe: Use cache entry if possible Masami Hiramatsu
2016-05-11 13:53 ` [PATCH perf/core v7 11/21] perf probe: Show all cached probes Masami Hiramatsu
2016-05-11 13:53 ` [PATCH perf/core v7 12/21] perf probe: Remove caches when --cache is given Masami Hiramatsu
2016-05-11 13:53 ` [PATCH perf/core v7 13/21] perf/sdt: ELF support for SDT Masami Hiramatsu
2016-05-11 13:53 ` [PATCH perf/core v7 14/21] perf probe: Add group name support Masami Hiramatsu
2016-05-11 13:54 ` [PATCH perf/core v7 15/21] perf buildid-cache: Scan and import user SDT events to probe cache Masami Hiramatsu
2016-05-11 13:54 ` [PATCH perf/core v7 16/21] perf probe: Accept %sdt and %cached event name Masami Hiramatsu
2016-05-11 13:54 ` [PATCH perf/core v7 17/21] perf-list: Show SDT and pre-cached events Masami Hiramatsu
2016-05-11 13:54 ` [PATCH perf/core v7 18/21] perf-list: Skip SDTs placed in invalid binaries Masami Hiramatsu
2016-05-11 13:54 ` [PATCH perf/core v7 19/21] perf probe: Allow wildcard for cached events Masami Hiramatsu
2016-05-11 13:54 ` [PATCH perf/core v7 20/21] perf probe: Support @BUILDID or @FILE suffix for SDT events Masami Hiramatsu
2016-05-11 13:55 ` [PATCH perf/core v7 21/21] perf probe: Support a special SDT probe format Masami Hiramatsu
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20160512104635.04a7368428091a9665f2ca19@kernel.org \
--to=mhiramat@kernel.org \
--cc=acme@kernel.org \
--cc=ananth@linux.vnet.ibm.com \
--cc=brendan.d.gregg@gmail.com \
--cc=hemant@linux.vnet.ibm.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@redhat.com \
--cc=namhyung@kernel.org \
--cc=peterz@infradead.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®