From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1425359AbcFHTIH (ORCPT ); Wed, 8 Jun 2016 15:08:07 -0400 Received: from mail-yw0-f195.google.com ([209.85.161.195]:32958 "EHLO mail-yw0-f195.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1423277AbcFHTIF (ORCPT ); Wed, 8 Jun 2016 15:08:05 -0400 Date: Wed, 8 Jun 2016 16:07:59 -0300 From: Gustavo Padovan To: Greg Kroah-Hartman Cc: linux-kernel@vger.kernel.org, devel@driverdev.osuosl.org, dri-devel@lists.freedesktop.org, Daniel Stone , Arve =?iso-8859-1?B?SGr4bm5lduVn?= , Riley Andrews , Daniel Vetter , Rob Clark , Greg Hackmann , John Harrison , Maarten Lankhorst , Sumit Semwal , Gustavo Padovan Subject: Re: [PATCH 00/18] staging/android: clean up SW_SYNC Message-ID: <20160608190759.GB2360@joana> Mail-Followup-To: Gustavo Padovan , Greg Kroah-Hartman , linux-kernel@vger.kernel.org, devel@driverdev.osuosl.org, dri-devel@lists.freedesktop.org, Daniel Stone , Arve =?iso-8859-1?B?SGr4bm5lduVn?= , Riley Andrews , Daniel Vetter , Rob Clark , Greg Hackmann , John Harrison , Maarten Lankhorst , Sumit Semwal , Gustavo Padovan References: <1464724753-2490-1-git-send-email-gustavo@padovan.org> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <1464724753-2490-1-git-send-email-gustavo@padovan.org> User-Agent: Mutt/1.6.1 (2016-04-27) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Hi Greg, Any comment on this? Gustavo 2016-05-31 Gustavo Padovan : > From: Gustavo Padovan > > Hi, > > The following patches do a clean up on the sw_sync inteface. It starts by > removing struct sync_timeline_ops, which was creating unecessary wrappers > in the code and the start to organize the sync_timeline and sw_sync code > better. > > sw_sync interface was moved to sw_sync.c along with sync_timeline - which > is now internal to sw_sync. > > The next step after this work is the actual de-stage of SW_SYNC and > the upstreaming of selftests for sw_sync and sync_file. > > Please review! > > Gustavo > > --- > > Gustavo Padovan (18): > staging/android: store last signaled value on sync timeline > staging/android: remove .{fence,timeline}_value_str() from timeline_ops > staging/android: remove struct sync_timeline_ops > staging/android: remove sw_sync_timeline and sw_sync_pt > staging/android: remove sw_sync.[ch] files > staging/android: rename android_fence to timeline_fence > staging/android: remove unnecessary check for fence > staging/android: remove size arg of sync_timeline_create() > staging/android: bring struct sync_pt back > staging/android: move sw_sync related code to sw_sync.c > staging/android: clean up #includes in the sync framework > staging/android: make sync_timeline internal to sw_sync > staging/android: make sw_ioctl info internal to sw_sync.c > staging/android: remove 'destroyed' member from struct sync_timeline > staging/android: remove sync_timeline_destroy() > staging/android: remove drv_name from sync_timeline > staging/android: rename sync.h to sync_debug.h > staging/android: add DEBUG_FS dependence on Kconfig > > drivers/staging/android/Kconfig | 17 +- > drivers/staging/android/Makefile | 3 +- > drivers/staging/android/sw_sync.c | 341 ++++++++++++++++++++++++++++----- > drivers/staging/android/sw_sync.h | 59 ------ > drivers/staging/android/sync.c | 221 --------------------- > drivers/staging/android/sync.h | 154 --------------- > drivers/staging/android/sync_debug.c | 154 +-------------- > drivers/staging/android/sync_debug.h | 83 ++++++++ > drivers/staging/android/trace/sync.h | 14 +- > drivers/staging/android/uapi/sw_sync.h | 32 ---- > include/linux/fence.h | 2 - > 11 files changed, 399 insertions(+), 681 deletions(-) > delete mode 100644 drivers/staging/android/sw_sync.h > delete mode 100644 drivers/staging/android/sync.c > delete mode 100644 drivers/staging/android/sync.h > create mode 100644 drivers/staging/android/sync_debug.h > delete mode 100644 drivers/staging/android/uapi/sw_sync.h > > -- > 2.5.5 >