From: kbuild test robot <lkp@intel.com>
To: Boris Brezillon <boris.brezillon@free-electrons.com>
Cc: kbuild-all@01.org, David Woodhouse <dwmw2@infradead.org>,
Brian Norris <computersforpeace@gmail.com>,
linux-mtd@lists.infradead.org,
Boris Brezillon <boris.brezillon@free-electrons.com>,
Richard Weinberger <richard@nod.at>,
Hans de Goede <hdegoede@redhat.com>,
linux-kernel@vger.kernel.org, Aleksei Mamlin <mamlinav@gmail.com>
Subject: Re: [PATCH v2 14/15] mtd: nand: hynix: rework NAND ID decoding to extract more information
Date: Wed, 8 Jun 2016 22:34:35 +0800 [thread overview]
Message-ID: <201606082245.AcPdRo4H%fengguang.wu@intel.com> (raw)
In-Reply-To: <1465390849-13199-15-git-send-email-boris.brezillon@free-electrons.com>
[-- Attachment #1: Type: text/plain, Size: 2253 bytes --]
Hi,
[auto build test ERROR on mtd/master]
[also build test ERROR on v4.7-rc2 next-20160608]
[if your patch is applied to the wrong git tree, please drop us a note to help improve the system]
url: https://github.com/0day-ci/linux/commits/Boris-Brezillon/mtd-nand-allow-vendor-specific-detection-initialization/20160608-210755
base: git://git.infradead.org/linux-mtd.git master
config: x86_64-randconfig-s3-06081945 (attached as .config)
compiler: gcc-6 (Debian 6.1.1-1) 6.1.1 20160430
reproduce:
# save the attached .config to linux build tree
make ARCH=x86_64
All errors (new ones prefixed by >>):
drivers/mtd/nand/nand_hynix.c: In function 'hynix_nand_decode_id':
>> drivers/mtd/nand/nand_hynix.c:239:20: error: 'SZ_1M' undeclared (first use in this function)
mtd->erasesize = SZ_1M << tmp;
^~~~~
drivers/mtd/nand/nand_hynix.c:239:20: note: each undeclared identifier is reported only once for each function it appears in
>> drivers/mtd/nand/nand_hynix.c:241:20: error: 'SZ_512K' undeclared (first use in this function)
mtd->erasesize = SZ_512K + SZ_256K;
^~~~~~~
>> drivers/mtd/nand/nand_hynix.c:241:30: error: 'SZ_256K' undeclared (first use in this function)
mtd->erasesize = SZ_512K + SZ_256K;
^~~~~~~
>> drivers/mtd/nand/nand_hynix.c:243:20: error: 'SZ_128K' undeclared (first use in this function)
mtd->erasesize = SZ_128K << tmp;
^~~~~~~
vim +/SZ_1M +239 drivers/mtd/nand/nand_hynix.c
233 * we start counting at 128KiB and shift this value the content of
234 * ID[3][4:5].
235 * The only exception is when ID[3][4:5] == 3 and ID[3][7] == 0, in
236 * this case the erasesize is set to 768KiB.
237 */
238 if (chip->id.data[3] & 0x80)
> 239 mtd->erasesize = SZ_1M << tmp;
240 else if (tmp == 3)
> 241 mtd->erasesize = SZ_512K + SZ_256K;
242 else
> 243 mtd->erasesize = SZ_128K << tmp;
244
245 /*
246 * Modern Toggle DDR NANDs have a valid JEDECID even though they are
---
0-DAY kernel test infrastructure Open Source Technology Center
https://lists.01.org/pipermail/kbuild-all Intel Corporation
[-- Attachment #2: .config.gz --]
[-- Type: application/octet-stream, Size: 26572 bytes --]
next prev parent reply other threads:[~2016-06-08 14:17 UTC|newest]
Thread overview: 24+ messages / expand[flat|nested] mbox.gz Atom feed top
2016-06-08 13:00 [PATCH v2 00/15] mtd: nand: allow vendor specific detection/initialization Boris Brezillon
2016-06-08 13:00 ` [PATCH v2 01/15] mtd: nand: get rid of the mtd parameter in all auto-detection functions Boris Brezillon
2016-06-08 13:00 ` [PATCH v2 02/15] mtd: nand: store nand ID in struct nand_chip Boris Brezillon
2016-06-08 13:00 ` [PATCH v2 03/15] mtd: nand: get rid of busw parameter Boris Brezillon
2016-06-08 13:00 ` [PATCH v2 04/15] mtd: nand: rename nand_get_flash_type() into nand_detect() Boris Brezillon
2016-06-08 13:00 ` [PATCH v2 05/15] mtd: nand: add manufacturer specific initialization/detection steps Boris Brezillon
2016-06-18 9:23 ` Richard Weinberger
2016-06-18 11:31 ` Boris Brezillon
2016-06-18 11:40 ` Boris Brezillon
2016-06-18 11:34 ` Boris Brezillon
2016-06-18 12:34 ` Richard Weinberger
2016-06-08 13:00 ` [PATCH v2 06/15] mtd: nand: kill the MTD_NAND_IDS Kconfig option Boris Brezillon
2016-06-08 13:00 ` [PATCH v2 07/15] mtd: nand: move Samsung specific init/detection logic in nand_samsung.c Boris Brezillon
2016-06-08 13:00 ` [PATCH v2 08/15] mtd: nand: move Hynix specific init/detection logic in nand_hynix.c Boris Brezillon
2016-06-08 13:00 ` [PATCH v2 09/15] mtd: nand: move Toshiba specific init/detection logic in nand_toshiba.c Boris Brezillon
2016-06-08 13:00 ` [PATCH v2 10/15] mtd: nand: move Micron specific init logic in nand_micron.c Boris Brezillon
2016-06-08 13:00 ` [PATCH v2 11/15] mtd: nand: move AMD/Spansion specific init/detection logic in nand_amd.c Boris Brezillon
2016-06-08 13:00 ` [PATCH v2 12/15] mtd: nand: move Macronix specific initialization in nand_macronix.c Boris Brezillon
2016-06-08 13:00 ` [PATCH v2 13/15] mtd: nand: samsung: retrieve ECC requirements from extended ID Boris Brezillon
2016-06-08 13:00 ` [PATCH v2 14/15] mtd: nand: hynix: rework NAND ID decoding to extract more information Boris Brezillon
2016-06-08 14:34 ` kbuild test robot [this message]
2016-06-08 13:00 ` [PATCH v2 15/15] mtd: nand: hynix: add read-retry support for 1x nm MLC NANDs Boris Brezillon
2016-06-18 22:09 ` [PATCH v2 00/15] mtd: nand: allow vendor specific detection/initialization Richard Weinberger
2016-06-19 8:34 ` Boris Brezillon
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=201606082245.AcPdRo4H%fengguang.wu@intel.com \
--to=lkp@intel.com \
--cc=boris.brezillon@free-electrons.com \
--cc=computersforpeace@gmail.com \
--cc=dwmw2@infradead.org \
--cc=hdegoede@redhat.com \
--cc=kbuild-all@01.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mtd@lists.infradead.org \
--cc=mamlinav@gmail.com \
--cc=richard@nod.at \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®