From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1751208AbcFIMSI (ORCPT ); Thu, 9 Jun 2016 08:18:08 -0400 Received: from mail-wm0-f68.google.com ([74.125.82.68]:36003 "EHLO mail-wm0-f68.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1750796AbcFIMSF (ORCPT ); Thu, 9 Jun 2016 08:18:05 -0400 Date: Thu, 9 Jun 2016 14:18:02 +0200 From: Michal Hocko To: Johannes Weiner Cc: linux-mm@kvack.org, linux-kernel@vger.kernel.org, Andrew Morton , Rik van Riel , Mel Gorman , Andrea Arcangeli , Andi Kleen , Tim Chen , kernel-team@fb.com Subject: Re: [PATCH 07/10] mm: base LRU balancing on an explicit cost model Message-ID: <20160609121802.GD24777@dhcp22.suse.cz> References: <20160606194836.3624-1-hannes@cmpxchg.org> <20160606194836.3624-8-hannes@cmpxchg.org> <20160608125137.GH22570@dhcp22.suse.cz> <20160608161605.GF6727@cmpxchg.org> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <20160608161605.GF6727@cmpxchg.org> User-Agent: Mutt/1.6.0 (2016-04-01) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Wed 08-06-16 12:16:05, Johannes Weiner wrote: > On Wed, Jun 08, 2016 at 02:51:37PM +0200, Michal Hocko wrote: > > On Mon 06-06-16 15:48:33, Johannes Weiner wrote: > > > Rename struct zone_reclaim_stat to struct lru_cost, and move from two > > > separate value ratios for the LRU lists to a relative LRU cost metric > > > with a shared denominator. > > > > I just do not like the too generic `number'. I guess cost or price would > > fit better and look better in the code as well. Up you though... > > Yeah, I picked it as a pair, numerator and denominator. But as Minchan > points out, denom is superfluous in the final version of the patch, so > I'm going to remove it and give the numerators better names. > > anon_cost and file_cost? Yes that is much more descriptive and easier to grep for. I didn't propose that because I thought you would want to preserve the array definition for an easier code to update them. -- Michal Hocko SUSE Labs