From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1422756AbcFMKl0 (ORCPT ); Mon, 13 Jun 2016 06:41:26 -0400 Received: from ns.sciencehorizons.net ([71.41.210.147]:23259 "HELO ns.sciencehorizons.net" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with SMTP id S964971AbcFMKlZ (ORCPT ); Mon, 13 Jun 2016 06:41:25 -0400 Date: 13 Jun 2016 06:41:22 -0400 Message-ID: <20160613104122.30341.qmail@ns.sciencehorizons.net> From: "George Spelvin" To: tglx@linutronix.de Subject: Re: [patch 11/20] hlist: Add hlist_is_last_node() helper Cc: linux@sciencehorizons.net, linux-kernel@vger.kernel.org Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Shouldn't this function be called hlist_is_only_node()? hlist_is_last_node would be simply !n->next, as "last" doesn't imply the lack of others. I understand how the name might make sense in the context of removing entries from the list, but in other contexts, it's confusing.