From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1751663AbcFTT2m (ORCPT ); Mon, 20 Jun 2016 15:28:42 -0400 Received: from mail-yw0-f193.google.com ([209.85.161.193]:35746 "EHLO mail-yw0-f193.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1752902AbcFTT2d (ORCPT ); Mon, 20 Jun 2016 15:28:33 -0400 Date: Mon, 20 Jun 2016 15:27:08 -0400 From: Tejun Heo To: Petr Mladek Cc: Andrew Morton , Oleg Nesterov , Ingo Molnar , Peter Zijlstra , Steven Rostedt , "Paul E. McKenney" , Josh Triplett , Thomas Gleixner , Linus Torvalds , Jiri Kosina , Borislav Petkov , Michal Hocko , linux-mm@kvack.org, Vlastimil Babka , linux-api@vger.kernel.org, linux-kernel@vger.kernel.org Subject: Re: [PATCH v9 02/12] kthread: Kthread worker API cleanup Message-ID: <20160620192708.GT3262@mtj.duckdns.org> References: <1466075851-24013-1-git-send-email-pmladek@suse.com> <1466075851-24013-3-git-send-email-pmladek@suse.com> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <1466075851-24013-3-git-send-email-pmladek@suse.com> User-Agent: Mutt/1.6.1 (2016-04-27) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Hello, On Thu, Jun 16, 2016 at 01:17:21PM +0200, Petr Mladek wrote: > __init_kthread_worker() -> __kthread_init_worker() > init_kthread_worker() -> kthread_init_worker() > init_kthread_work() -> kthread_init_work() > insert_kthread_work() -> kthread_insert_work() > queue_kthread_work() -> kthread_queue_work() > flush_kthread_work() -> kthread_flush_work() > flush_kthread_worker() -> kthread_flush_worker() I wonder whether the subsystem name here is more the whole kthread_worker rather than just kthread but I can't think of a good single syllable abbrev for it. It's a bikeshedding anyway. > Note that the names of DEFINE_KTHREAD_WORK*() macros stay > as they are. It is common that the "DEFINE_" prefix has > precedence over the subsystem names. > > INIT_() macros are similar to DEFINE_. Therefore this patch > renames: > > KTHREAD_WORKER_INIT() -> INIT_KTHREAD_WORKER() > KTHREAD_WORK_INIT() -> INIT_KTHREAD_WORK() So, they're different. In the above cases, INIT doesn't stand for the verb INITIALIZE but its noun form INITIALIZER. These aren't operations and thus different from DEFINE_XXX(). kthread_init_worker = kthread: initialize worker KTHREAD_WORKER_INIT = kthread: worker initializer I think it makes a lot more sense to keep _INIT at the end for these. Thanks. -- tejun