From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1755534AbcGFS2e (ORCPT ); Wed, 6 Jul 2016 14:28:34 -0400 Received: from outbound1a.ore.mailhop.org ([54.213.22.21]:22106 "EHLO outbound1a.ore.mailhop.org" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1754490AbcGFS2d (ORCPT ); Wed, 6 Jul 2016 14:28:33 -0400 X-MHO-User: 8825da4d-43a7-11e6-a0ff-e511cd071b9b X-Report-Abuse-To: https://support.duocircle.com/support/solutions/articles/5000540958-duocircle-standard-smtp-abuse-information X-Originating-IP: 74.99.78.160 X-Mail-Handler: DuoCircle Outbound SMTP X-DKIM: OpenDKIM Filter v2.6.8 io 65DF880159 Date: Wed, 6 Jul 2016 18:28:23 +0000 From: Jason Cooper To: Zhao Qiang Cc: oss@buserror.net, tglx@linutronix.de, marc.zyngier@arm.com, linuxppc-dev@lists.ozlabs.org, linux-kernel@vger.kernel.org, xiaobo.xie@nxp.com Subject: Re: [PATCH v2 1/2] irqchip/qeic: merge qeic init code from platforms to a common function Message-ID: <20160706182823.GM3348@io.lakedaemon.net> References: <1467784901-11615-1-git-send-email-qiang.zhao@nxp.com> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <1467784901-11615-1-git-send-email-qiang.zhao@nxp.com> User-Agent: Mutt/1.5.21 (2010-09-15) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Hi Zhao Qiang, On Wed, Jul 06, 2016 at 02:01:38PM +0800, Zhao Qiang wrote: > The codes of qe_ic init from a variety of platforms are redundant, > merge them to a common function and put it to irqchip/qe_ic.c > > For non-p1021_mds mpc85xx_mds boards, use "qe_ic_init(np, 0, > qe_ic_cascade_low_mpic, qe_ic_cascade_high_mpic);" instead of > "qe_ic_init(np, 0, qe_ic_cascade_muxed_mpic, NULL);". > > qe_ic_cascade_muxed_mpic was used for boards has the same interrupt > number for low interrupt and high interrupt, qe_ic_init has checked > if "low interrupt == high interrupt" > > Signed-off-by: Zhao Qiang > --- > Changes for v2: > - modify subject and commit msg > - add check for qeic by type > > arch/powerpc/platforms/83xx/misc.c | 15 --------------- > arch/powerpc/platforms/85xx/corenet_generic.c | 9 --------- > arch/powerpc/platforms/85xx/mpc85xx_mds.c | 14 -------------- > arch/powerpc/platforms/85xx/mpc85xx_rdb.c | 16 ---------------- > arch/powerpc/platforms/85xx/twr_p102x.c | 14 -------------- > drivers/irqchip/qe_ic.c | 16 ++++++++++++++++ > 6 files changed, 16 insertions(+), 68 deletions(-) Hmmm, I seem to be missing the patch moving qe_ic.c into drivers/irqchip/ ... :-/ Please resend with it attached. Also, while we're here, please follow the file naming convention inside the drivers/irqchip/ directory. Something like drivers/irqchip/irq-qeic.c thx, Jason.