From: Jessica Yu <jeyu@redhat.com>
To: Petr Mladek <pmladek@suse.com>
Cc: Josh Poimboeuf <jpoimboe@redhat.com>,
Miroslav Benes <mbenes@suse.cz>, Jiri Kosina <jikos@kernel.org>,
Chris J Arges <chris.j.arges@canonical.com>,
Eugene Shatokhin <eugene.shatokhin@rosalab.ru>,
live-patching@vger.kernel.org, x86@kernel.org,
linux-kernel@vger.kernel.org
Subject: Re: Fix issue with alternatives/paravirt patches
Date: Thu, 7 Jul 2016 19:51:52 -0400 [thread overview]
Message-ID: <20160707235152.GC9954@packer-debian-8-amd64.digitalocean.com> (raw)
In-Reply-To: <20160707155633.GC3556@pathway.suse.cz>
+++ Petr Mladek [07/07/16 17:56 +0200]:
>On Tue 2016-07-05 22:34:58, Jessica Yu wrote:
>> Hi,
>>
>> A few months ago, Chris Arges reported a bug involving alternatives/paravirt
>> patching that was discussed here [1] and here [2]. To briefly summarize the
>> bug, patch modules that contained .altinstructions or .parainstructions
>> sections would break because these alternative/paravirt patches would be
>> applied first by the module loader (see x86 module_finalize()), then
>> livepatch would later clobber these patches when applying per-object
>> relocations. This lead to crashes and unpredictable behavior.
>>
>> One conclusion we reached from our last discussion was that we will
>> need to introduce some arch-specific code to address this problem.
>> This patchset presents a possible fix for the bug by adding a new
>> arch-specific arch_klp_init_object_loaded() function that by default
>> does nothing but can be overridden by different arches.
>>
>> To fix this issue for x86, since we can access a patch module's Elf
>> sections through mod->klp_info, we can simply delay the calls to
>> apply_paravirt() and apply_alternatives() to arch_klp_init_object_loaded(),
>> which is called after relocations have been written for an object.
>> In addition, for patch modules, .parainstructions and .altinstructions are
>> prefixed by ".klp.arch.${objname}" so that the module loader ignores them
>> and livepatch can apply them manually.
>
>The solution looks correct to me. The fun will be how to generate
>the sections. If I get this correctly, it is not enough to rename
>the existing ones. Instead, we need to split .parainstructions
>and .altinstructions sections into per-object ones.
Hi Petr,
That is correct, this means .parainstructions and .altinstructions
will be split per-object and follow a similar naming scheme to the
existing .klp.rela.${objname} sections. Then, we can apply these
sections per-object with apply_alternatives() and apply_paravirt().
>I wonder if there is a plan for this. Especially I am interested
>into the patches created from sources ;-) I wonder if we could add
>a tag somewhere and improve the build infrastructure.
I currently have a working branch of the kpatch-build tools that
generates these sections. I'm hoping to get the code up in some shape
or form soon; I'll post an update when it's up.
Jessica
next prev parent reply other threads:[~2016-07-07 23:52 UTC|newest]
Thread overview: 15+ messages / expand[flat|nested] mbox.gz Atom feed top
2016-07-06 2:34 [PATCH 0/2] " Jessica Yu
2016-07-06 2:34 ` [PATCH 1/2] livepatch: use arch_klp_init_object_loaded() to finish arch-specific tasks Jessica Yu
2016-07-06 2:35 ` [PATCH 2/2] livepatch/x86: apply alternatives and paravirt patches after relocations Jessica Yu
2016-07-08 15:44 ` Josh Poimboeuf
2016-07-07 15:56 ` [PATCH 0/2] Fix issue with alternatives/paravirt patches Petr Mladek
2016-07-07 22:53 ` Josh Poimboeuf
2016-07-12 11:55 ` Miroslav Benes
2016-07-12 14:01 ` Josh Poimboeuf
2016-07-13 1:18 ` Jessica Yu
2016-07-07 23:51 ` Jessica Yu [this message]
2016-07-08 5:22 ` [PATCH 0/2] " Christopher Arges
2016-07-08 16:57 ` Jessica Yu
2016-07-12 12:06 ` [PATCH 0/2] " Miroslav Benes
2016-07-21 5:10 ` Jessica Yu
2016-07-21 8:48 ` Miroslav Benes
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20160707235152.GC9954@packer-debian-8-amd64.digitalocean.com \
--to=jeyu@redhat.com \
--cc=chris.j.arges@canonical.com \
--cc=eugene.shatokhin@rosalab.ru \
--cc=jikos@kernel.org \
--cc=jpoimboe@redhat.com \
--cc=linux-kernel@vger.kernel.org \
--cc=live-patching@vger.kernel.org \
--cc=mbenes@suse.cz \
--cc=pmladek@suse.com \
--cc=x86@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome