mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Andrew Vagin <avagin@virtuozzo.com>
To: James Bottomley <James.Bottomley@HansenPartnership.com>
Cc: "Eric W. Biederman" <ebiederm@xmission.com>,
	Linux API <linux-api@vger.kernel.org>,
	Containers <containers@lists.linux-foundation.org>,
	lkml <linux-kernel@vger.kernel.org>, <criu@openvz.org>,
	"Michael Kerrisk (man-pages)" <mtk.manpages@gmail.com>
Subject: Re: [CRIU] Introspecting userns relationships to other namespaces?
Date: Mon, 11 Jul 2016 13:55:00 -0700	[thread overview]
Message-ID: <20160711205459.GA5026@outlook.office365.com> (raw)
In-Reply-To: <1468184808.19833.30.camel@HansenPartnership.com>

On Mon, Jul 11, 2016 at 06:06:48AM +0900, James Bottomley wrote:
> On Sun, 2016-07-10 at 15:29 -0500, Eric W. Biederman wrote:
> > Andrew Vagin <avagin@virtuozzo.com> writes:
> > 
> > > On Fri, Jul 08, 2016 at 10:13:08PM -0500, Eric W. Biederman wrote:
> > > > "W. Trevor King" <wking@tremily.us> writes:
> > > > 
> > > > > On Thu, Jul 07, 2016 at 08:01:52AM -0700, James Bottomley
> > > > > wrote:
> > > > > > In theory, we could get nsfs to show this information as an
> > > > > > option
> > > > > > (just add a show_options entry to the superblock ops), but
> > > > > > the
> > > > > > problem is that although each namespace has a parent user_ns,
> > > > > > there's no way to get it without digging in the namespace
> > > > > > specific
> > > > > > structure.  Probably we should restructure to move it into
> > > > > > ns_common, then we could display it (and enforce all
> > > > > > namespaces
> > > > > > having owning user_ns) but it would be a reasonably large
> > > > > > (but
> > > > > > mechanical) change.
> > > > > 
> > > > > It sounds like everyone is either positive or or neutral on
> > > > > this
> > > > > groundwork, even if we haven't decided if/how to expose the
> > > > > information to userspace.  I'm happy to work up a patch while
> > > > > the rest
> > > > > of the discussion continues.  I'm also happy to let someone
> > > > > else work
> > > > > up the patch, if anyone else is chomping at the bit ;).
> > > > 
> > > > I am dubious on moving all of the user namespace members into
> > > > ns_common.
> > > > 
> > > > I would happy to be proved wrong but I suspect in the cases where
> > > > we
> > > > actually use that user namespace the code will become uglier. 
> > > >  Making
> > > > the ordinary uses uglier to make a rare corner case nicer is the
> > > > wrong
> > > > trade off.
> > > > 
> > > > But feel free to try it is certainly worth doing if it doesn't
> > > > make the
> > > > code that uses the user namespaces uglier.
> > > 
> > > If it's interesting for someone, I have this patch in my tree
> > > https://github.com/avagin/linux-task-diag/commit/63b32df68ae8d3a384
> > > 2bae42bbcae3468db76d85
> > > 
> > > I can't say that it makes something uglier.
> > 
> > I have only skimmed things but overall it looks better than I had
> > feared.
> 
> It looks about as messy as I feared, but since someone else has done
> all the hard work, I'm happy.
> 
> > At the same time I really really don't like losing the parent pointer 
> > in the user namespace case.  That is seriously obfuscating.

We can do something like this:

@@ -27,11 +27,13 @@ struct user_namespace {
...
-       struct ns_common        ns;
+       union {
+               struct user_namespace   *parent;
+               struct ns_common        ns;
+       };
        unsigned long           flags;
...
@@ -97,6 +97,7 @@ int create_user_ns(struct cred *new)
...
        atomic_set(&ns->count, 1);
        /* Leave the new->user_ns reference with the new user namespace. */
+       BUILD_BUG_ON(&ns->ns.user_ns != &ns->parent);
        ns->parent = parent_ns;

> 
> Because it has a slightly different meaning from all other namespaces? 
>  If I assume that's what you mean, I think looking at it in a different
> way can solve the problem:  The pointer in ns_common is always to the
> owning user_ns, so we can label it as such.  Even for a child user_ns,
> the owning user_ns is simply the parent.  I think it makes logical
> sense to think of all user_ns to namespace relationships as
> owning/owned rather than most as owning/owned and some as parent/child.

I think we can rename ns.user_ns to ns.owner or ns.owner_ns.


Thanks,
Andrew

> 
> James
> 
> > Eric
> > 
> > _______________________________________________
> > Containers mailing list
> > Containers@lists.linux-foundation.org
> > https://lists.linuxfoundation.org/mailman/listinfo/containers
> > 
> 

      reply	other threads:[~2016-07-11 21:09 UTC|newest]

Thread overview: 46+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
     [not found] <c2a26220-69f2-f2f5-491a-e43abd9a6f92@gmail.com>
     [not found] ` <87r3b7pxja.fsf@x220.int.ebiederm.org>
2016-07-06  8:41   ` Michael Kerrisk (man-pages)
2016-07-06 14:13     ` Serge E. Hallyn
2016-07-06 15:46       ` Eric W. Biederman
2016-07-08  1:57         ` [CRIU] " Andrew Vagin
2016-07-08  7:44           ` Eric W. Biederman
2016-07-08 14:35             ` James Bottomley
2016-07-08 20:38               ` Andrew Vagin
2016-07-08 20:50                 ` W. Trevor King
2016-07-08 22:19                 ` James Bottomley
2016-07-08 22:19                 ` James Bottomley
2016-07-08 23:52                   ` Eric W. Biederman
2016-07-09  0:15                     ` James Bottomley
2016-07-09  3:05                       ` Eric W. Biederman
2016-07-09  7:26                         ` Andrew Vagin
2016-07-09 10:31                           ` James Bottomley
2016-07-09 10:32                           ` James Bottomley
2016-07-09 18:15                           ` Eric W. Biederman
2016-07-09 18:29                             ` Eric W. Biederman
2016-07-13  0:08                               ` Andrew Vagin
2016-07-13  3:59                                 ` W. Trevor King
2016-07-07  8:15       ` Michael Kerrisk (man-pages)
2016-07-07 13:36         ` Serge E. Hallyn
2016-07-07 15:01           ` James Bottomley
2016-07-07 18:21             ` Michael Kerrisk (man-pages)
2016-07-07 18:24               ` Serge E. Hallyn
2016-07-07 19:17               ` James Bottomley
2016-07-08  2:16                 ` [CRIU] " Andrew Vagin
2016-07-08  3:00                   ` Andrew Vagin
2016-07-08  3:26                     ` James Bottomley
2016-07-08  5:26                       ` W. Trevor King
2016-07-08  6:16                         ` W. Trevor King
2016-07-08  6:54                         ` Andrew Vagin
2016-07-08  7:18                           ` W. Trevor King
2016-07-08  5:41                       ` [CRIU] " Andrei Vagin
2016-07-08  5:47                         ` Andrei Vagin
2016-07-08  6:07                         ` James Bottomley
2016-07-08 11:17                       ` Michael Kerrisk (man-pages)
2016-07-08  3:20                   ` James Bottomley
2016-07-08  6:09                     ` Andrew Vagin
2016-07-08 11:11                 ` Michael Kerrisk (man-pages)
2016-07-09  3:15             ` W. Trevor King
2016-07-09  3:13               ` Eric W. Biederman
2016-07-10  5:36                 ` [CRIU] " Andrew Vagin
2016-07-10 20:29                   ` Eric W. Biederman
2016-07-10 21:06                     ` James Bottomley
2016-07-11 20:55                       ` Andrew Vagin [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20160711205459.GA5026@outlook.office365.com \
    --to=avagin@virtuozzo.com \
    --cc=James.Bottomley@HansenPartnership.com \
    --cc=containers@lists.linux-foundation.org \
    --cc=criu@openvz.org \
    --cc=ebiederm@xmission.com \
    --cc=linux-api@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mtk.manpages@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®