From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1757416AbcHBSk1 (ORCPT ); Tue, 2 Aug 2016 14:40:27 -0400 Received: from mga01.intel.com ([192.55.52.88]:7894 "EHLO mga01.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1753932AbcHBLLw (ORCPT ); Tue, 2 Aug 2016 07:11:52 -0400 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.28,459,1464678000"; d="scan'208";a="743063424" From: Baole Ni To: tony.luck@intel.com, fenghua.yu@intel.com, robert.jarzmik@free.fr, linux@armlinux.org.uk Cc: linux-ia64@vger.kernel.org, linux-kernel@vger.kernel.org, chuansheng.liu@intel.com, baolex.ni@intel.com Subject: [PATCH 0012/1285] Replace numeric parameter like 0444 with macro Date: Tue, 2 Aug 2016 18:34:12 +0800 Message-Id: <20160802103412.14554-1-baolex.ni@intel.com> X-Mailer: git-send-email 2.9.2 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu Signed-off-by: Baole Ni --- arch/ia64/kernel/mca_drv.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/arch/ia64/kernel/mca_drv.c b/arch/ia64/kernel/mca_drv.c index 94f8bf7..3d04e56 100644 --- a/arch/ia64/kernel/mca_drv.c +++ b/arch/ia64/kernel/mca_drv.c @@ -788,7 +788,7 @@ void __exit mca_external_handler_exit(void) module_init(mca_external_handler_init); module_exit(mca_external_handler_exit); -module_param(sal_rec_max, int, 0644); +module_param(sal_rec_max, int, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(sal_rec_max, "Max size of SAL error record"); MODULE_DESCRIPTION("ia64 platform dependent mca handler driver"); -- 2.9.2