From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1754574AbcHBLNr (ORCPT ); Tue, 2 Aug 2016 07:13:47 -0400 Received: from mga02.intel.com ([134.134.136.20]:61370 "EHLO mga02.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1754344AbcHBLNd (ORCPT ); Tue, 2 Aug 2016 07:13:33 -0400 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.28,459,1464678000"; d="scan'208";a="149286364" From: Baole Ni To: tglx@linutronix.de, mingo@redhat.com, hpa@zytor.com, x86@kernel.org Cc: linux-kernel@vger.kernel.org, jikos@kernel.org, adam.buchbinder@gmail.com, mcgrof@kernel.org, chuansheng.liu@intel.com, baolex.ni@intel.com Subject: [PATCH 0031/1285] Replace numeric parameter like 0444 with macro Date: Tue, 2 Aug 2016 18:35:47 +0800 Message-Id: <20160802103547.15841-1-baolex.ni@intel.com> X-Mailer: git-send-email 2.9.2 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu Signed-off-by: Baole Ni --- arch/x86/kernel/apm_32.c | 18 +++++++++--------- 1 file changed, 9 insertions(+), 9 deletions(-) diff --git a/arch/x86/kernel/apm_32.c b/arch/x86/kernel/apm_32.c index c7364bd..729932f 100644 --- a/arch/x86/kernel/apm_32.c +++ b/arch/x86/kernel/apm_32.c @@ -2422,27 +2422,27 @@ module_exit(apm_exit); MODULE_AUTHOR("Stephen Rothwell"); MODULE_DESCRIPTION("Advanced Power Management"); MODULE_LICENSE("GPL"); -module_param(debug, bool, 0644); +module_param(debug, bool, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(debug, "Enable debug mode"); -module_param(power_off, bool, 0444); +module_param(power_off, bool, S_IRUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(power_off, "Enable power off"); -module_param(bounce_interval, int, 0444); +module_param(bounce_interval, int, S_IRUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(bounce_interval, "Set the number of ticks to ignore suspend bounces"); -module_param(allow_ints, bool, 0444); +module_param(allow_ints, bool, S_IRUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(allow_ints, "Allow interrupts during BIOS calls"); -module_param(broken_psr, bool, 0444); +module_param(broken_psr, bool, S_IRUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(broken_psr, "BIOS has a broken GetPowerStatus call"); -module_param(realmode_power_off, bool, 0444); +module_param(realmode_power_off, bool, S_IRUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(realmode_power_off, "Switch to real mode before powering off"); -module_param(idle_threshold, int, 0444); +module_param(idle_threshold, int, S_IRUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(idle_threshold, "System idle percentage above which to make APM BIOS idle calls"); -module_param(idle_period, int, 0444); +module_param(idle_period, int, S_IRUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(idle_period, "Period (in sec/100) over which to caculate the idle percentage"); -module_param(smp, bool, 0444); +module_param(smp, bool, S_IRUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(smp, "Set this to enable APM use on an SMP platform. Use with caution on older systems"); MODULE_ALIAS_MISCDEV(APM_MINOR_DEV); -- 2.9.2