mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Baole Ni <baolex.ni@intel.com>
To: rui.zhang@intel.com, rjw@rjwysocki.net, lenb@kernel.org,
	x86@kernel.org, hpa@zytor.com
Cc: linux-acpi@vger.kernel.org, linux-kernel@vger.kernel.org,
	chuansheng.liu@intel.com, baolex.ni@intel.com, travis@sgi.com
Subject: [PATCH 0041/1285] Replace numeric parameter like 0444 with macro
Date: Tue,  2 Aug 2016 18:36:31 +0800	[thread overview]
Message-ID: <20160802103631.16505-1-baolex.ni@intel.com> (raw)

I find that the developers often just specified the numeric value
when calling a macro which is defined with a parameter for access permission.
As we know, these numeric value for access permission have had the corresponding macro,
and that using macro can improve the robustness and readability of the code,
thus, I suggest replacing the numeric parameter with the macro.

Signed-off-by: Chuansheng Liu <chuansheng.liu@intel.com>
Signed-off-by: Baole Ni <baolex.ni@intel.com>
---
 drivers/acpi/acpi_video.c | 12 ++++++------
 1 file changed, 6 insertions(+), 6 deletions(-)

diff --git a/drivers/acpi/acpi_video.c b/drivers/acpi/acpi_video.c
index c1d138e..cec427a 100644
--- a/drivers/acpi/acpi_video.c
+++ b/drivers/acpi/acpi_video.c
@@ -65,30 +65,30 @@ MODULE_DESCRIPTION("ACPI Video Driver");
 MODULE_LICENSE("GPL");
 
 static bool brightness_switch_enabled = 1;
-module_param(brightness_switch_enabled, bool, 0644);
+module_param(brightness_switch_enabled, bool, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH);
 
 /*
  * By default, we don't allow duplicate ACPI video bus devices
  * under the same VGA controller
  */
 static bool allow_duplicates;
-module_param(allow_duplicates, bool, 0644);
+module_param(allow_duplicates, bool, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH);
 
 static int disable_backlight_sysfs_if = -1;
-module_param(disable_backlight_sysfs_if, int, 0444);
+module_param(disable_backlight_sysfs_if, int, S_IRUSR | S_IRGRP | S_IROTH);
 
 #define REPORT_OUTPUT_KEY_EVENTS		0x01
 #define REPORT_BRIGHTNESS_KEY_EVENTS		0x02
 static int report_key_events = -1;
-module_param(report_key_events, int, 0644);
+module_param(report_key_events, int, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH);
 MODULE_PARM_DESC(report_key_events,
 	"0: none, 1: output changes, 2: brightness changes, 3: all");
 
 static bool device_id_scheme = false;
-module_param(device_id_scheme, bool, 0444);
+module_param(device_id_scheme, bool, S_IRUSR | S_IRGRP | S_IROTH);
 
 static bool only_lcd = false;
-module_param(only_lcd, bool, 0444);
+module_param(only_lcd, bool, S_IRUSR | S_IRGRP | S_IROTH);
 
 static int register_count;
 static DEFINE_MUTEX(register_count_mutex);
-- 
2.9.2

                 reply	other threads:[~2016-08-02 18:22 UTC|newest]

Thread overview: [no followups] expand[flat|nested]  mbox.gz  Atom feed

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20160802103631.16505-1-baolex.ni@intel.com \
    --to=baolex.ni@intel.com \
    --cc=chuansheng.liu@intel.com \
    --cc=hpa@zytor.com \
    --cc=lenb@kernel.org \
    --cc=linux-acpi@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=rjw@rjwysocki.net \
    --cc=rui.zhang@intel.com \
    --cc=travis@sgi.com \
    --cc=x86@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®