From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1753778AbcHBLdY (ORCPT ); Tue, 2 Aug 2016 07:33:24 -0400 Received: from mga01.intel.com ([192.55.52.88]:43983 "EHLO mga01.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1755879AbcHBLdK (ORCPT ); Tue, 2 Aug 2016 07:33:10 -0400 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.28,459,1464678000"; d="scan'208";a="743065210" From: Baole Ni To: mst@redhat.com, pjk1939@linux.vnet.ibm.com, pavel@ucw.cz, gregkh@linuxfoundation.org, hpa@zytor.com, x86@kernel.org Cc: virtualization@lists.linux-foundation.org, linux-kernel@vger.kernel.org, chuansheng.liu@intel.com, baolex.ni@intel.com, martin.petersen@oracle.com, kent.overstreet@gmail.com Subject: [PATCH 0095/1285] Replace numeric parameter like 0444 with macro Date: Tue, 2 Aug 2016 18:40:17 +0800 Message-Id: <20160802104017.20091-1-baolex.ni@intel.com> X-Mailer: git-send-email 2.9.2 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu Signed-off-by: Baole Ni --- drivers/block/virtio_blk.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/block/virtio_blk.c b/drivers/block/virtio_blk.c index 42758b5..786a393 100644 --- a/drivers/block/virtio_blk.c +++ b/drivers/block/virtio_blk.c @@ -561,7 +561,7 @@ static struct blk_mq_ops virtio_mq_ops = { }; static unsigned int virtblk_queue_depth; -module_param_named(queue_depth, virtblk_queue_depth, uint, 0444); +module_param_named(queue_depth, virtblk_queue_depth, uint, S_IRUSR | S_IRGRP | S_IROTH); static int virtblk_probe(struct virtio_device *vdev) { -- 2.9.2