From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1754836AbcHBL2n (ORCPT ); Tue, 2 Aug 2016 07:28:43 -0400 Received: from mga01.intel.com ([192.55.52.88]:5643 "EHLO mga01.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1754188AbcHBLTQ (ORCPT ); Tue, 2 Aug 2016 07:19:16 -0400 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.28,459,1464678000"; d="scan'208";a="858084209" From: Baole Ni To: minyard@acm.org, gustavo@padovan.org, johan.hedberg@gmail.com, gregkh@linuxfoundation.org, hpa@zytor.com, x86@kernel.org Cc: openipmi-developer@lists.sourceforge.net, linux-kernel@vger.kernel.org, chuansheng.liu@intel.com, baolex.ni@intel.com, jslaby@suse.cz, peter@korsgaard.com, lee.jones@linaro.org Subject: [PATCH 0101/1285] Replace numeric parameter like 0444 with macro Date: Tue, 2 Aug 2016 18:40:44 +0800 Message-Id: <20160802104044.20489-1-baolex.ni@intel.com> X-Mailer: git-send-email 2.9.2 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu Signed-off-by: Baole Ni --- drivers/char/ipmi/ipmi_bt_sm.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/char/ipmi/ipmi_bt_sm.c b/drivers/char/ipmi/ipmi_bt_sm.c index feafdab..55a4cdc 100644 --- a/drivers/char/ipmi/ipmi_bt_sm.c +++ b/drivers/char/ipmi/ipmi_bt_sm.c @@ -44,7 +44,7 @@ static int bt_debug; /* 0 == BT_DEBUG_OFF */ -module_param(bt_debug, int, 0644); +module_param(bt_debug, int, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(bt_debug, "debug bitmask, 1=enable, 2=messages, 4=states"); /* -- 2.9.2